ProcessMBS.QuitProcess does nothing?

I’m pretty sure that once upon a time the code below worked fine. In the latest MBS plugin it does nothing:

dim theBundleID as String = app.getMainAppBundleID ' com.mothsoftware.mailarchiverx dim maxProcess as ProcessMBS = Utility.getProcess(theBundleID) 'points to the running app if maxProcess <> Nil then dim theResult as Integer = maxProcess.QuitProcess if theResult <> 0 then Return Replace(kErrorQuit, "<<appname>>", app.getInstallationAppName) end if end if

The result is: app is running, theResult = 0

Xojo 2017r1, 32bit, latest MBS, the Captain.

Well, this sends an AppleEvent with Quit.
I could check whether it works here.

[code]dim p as new ProcessMBS



if = “App Name” then
MsgBox p.Name

dim e as integer = p.QuitProcess

MsgBox "quit: "+str(e)

end if

loop until not p.GetNextProcess[/code]

works here.

An Applescript doesn’t work either (tell application xyz to quit).

On The Captain? (I love this btw) I just got tell application "Overflow" to quit to work in script editor, so does it not work when dragged into and run from Xojo?

I’m on The Captain for stability as well, so I’m happy to help you test things.

Additionally, Christian’s example code worked for me.

That’s very odd. I tested the AppleScript on Mojave and it worked fine. The last time the customer contacted me she was on the Captain, too.