Problems connecting to database

I have been using a PostgreSQL 10.3 database remotely with a Xojo 2018 r3 database quite successfully. The connection is established using SSL.

In one installation, the client is trying to log in using AT&T fiber network and Xojo is connecting initially but then getting errors when trying to access any data.

On the same computer, there is a public WiFi that they can connect to and everything runs fine. It’s just that when they are connected to their modem via ethernet or local WiFi they can’t use the Xojo application.

I have run a speed test and everything seems to be running with plenty of speed. There were some packets dropped when I checked the MTU settings, but that would slow things a bit but not kill the connection.

I am guessing AT&T is blocking something but I really can’t say for sure. I had a similar thing happen with a client using Verizon, but they just switched internet providers and that was the solution for them. I don’t believe this client has that option, so I would really like to figure out what it could be.

maybe you need to change the pg_hba.conf

It’s set to allow connections from anywhere.

# TYPE  DATABASE        USER            ADDRESS                 METHOD

# "local" is for Unix domain socket connections only
local   all             all                                     peer
# IPv4 local connections:
host    all             all               md5
# IPv6 local connections:
host    all             all             ::1/128                 md5
# Allow replication connections from localhost, by a user with the
# replication privilege.
local   replication     all                                     peer
host    replication     all               md5
host    replication     all             ::1/128                 md5
#allow all connections to server
host    all             all                  md5

I think you might have to change the postgressql.config file also. It’s in the same directory as the hba file. Not at my computer but I think you have to change “listen” from local to “*”.