Problem with wrapping under Catalina

After updating to Catalina, all was fine until I loaded the most recent update.
Then I had to migrate my licence for Xojo. After doing that, I built my app and tried to wrap it with apoWrapper.

I got the following message.

codesign: /Users/phil/Library/Caches/com.ohanaware.appWrapper3/App Wrapper 3: replacing existing signature
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
/Users/phil/Library/Caches/com.ohanaware.appWrapper3/App Wrapper 3: the codesign_allocate helper tool cannot be found or used

macOS 10.15.1 (19B88)
App Wrapper 3 3.10.2 (359)

Sam fro Ihanaware sent me a new build of AppErapper, but I still had the same problem.

I went looking for answers on
They recommended using a terminal to run:
sudo xcode-select --install
sudo xcode-select -switch

I ran these commands one after the other in terminal, and despite the system telling me that they had not been installed, I was now able to use appWrappee to wrap my application, code sign and install it.

Hope that helps someone else with the same problem.

This bit me about a year ago. If you have a just-updated Xcode installation you don’t necessarily have the command line tools installed. It helps to launch Xcode and sit through that “installing additional components” dialog that occurs on first-run.

I’m a Homebrew user (referenced in the link you gave), and it is also helpful in and of itself with finding these issues.

I am trying to automate this process as it’s always a PITA when it happens. There appears to be the functionality to do it (the terminal commands you mention), it just takes a long time to test because I have to wipe the HDD, re-install the OS, then re-install the dev tools to be able to test it.

I run windoze under VMware and it goes much better than on any native machine.
Just an idea.
And a big shout out to Ohanaware and Sam for his promptly assistance and terrific software. I must remember to read the manual sometime…

Recently I notized that XCode has been updated again. Forgot to “Install additional components” at first, and hopefully all will work now again.

Probably, XCode refuses to work because t requires to confirm a new (or updated) agreement, which must be fulfilled while logging in into their Apple Developer website.

When I updated Xcode, I ticked the box to “install additional components”, but it didn’t work properly.
I had to use a terminal to run

sudo xcode-select --install
sudo xcode-select -switch

Before I could get appWrapper to work - then it was fine.