Problem with remote desktop debugging

Hi Everyone

Fun day today trying to get remote debugger consistently working on a Raspberry Pi VM. It has been quite random i.e. would work a few times and then fail and is now failing, period. Setup\process is as follows:

Win 10 running Xojo 2022 r4.1

WMware on the same machine, running Raspberry Pi (v 5.10) in an x86 32-bit container.
Have installed libunwind8 on the Pi.

Win10: Using the sample Xojo Notes project (desktop version), selected Linux build and set architecture to x86 32 bit to match VM OS.

Pi:Fired up stub (unpacked from Remote Desktop Debugger 2.5 - Linux 32-bit.zip). Server Status: Listening on port 44553, though it did once display’not listening’. In both cases, a PortQry scan (from Win10) showed ‘Listening’ for TCP and ‘Listening or Filtered’ for UDP, on 44553.

Win10: Launched ‘run->remotely’ to Pi (static IP)

Win10: And Xojo throws up: ‘Failed to connect properly. The remote debugger stub could not be reached on the target computer’ followed by ‘unable to initiate remore debug session’.

Any observations or thoughts on options to try (have uninstalled and re-installed the remote debugger) would be much appreciated.

Try unchecking the auto launch option in the debugger and then run remotely and when the IDE switches to “waiting” launch the app manually from a terminal window. If there are any issues, they’ll show up there.

If he’s getting the “Failed to connect properly. The remote debugger stub could not be reached” error it seems unlikely he’ll ever get to the “waiting” part.

@Shane_Dark - any firewalls involved? Try turning them all off.

Right, in that case, if it’s working initially and then failing later, there was an issue in the IDE which limited the number of connections that could be made. Try quitting the debugger on the pi and restarting it.

Yes, I have to do this once an hour or so when doing remote debugging (Windows target), usually after a compile error. It’s been this way for decades…

I am unfamiliar with VMWare on Windows (I use VMWare Fusion on Mac), but I’d be curious about the IP address that the debugger stub is reporting, and whether the IDE “sees” it.

On Fusion, one sets the VM network connection to either “share with the Mac”, or to obtain an address on the user’s LAN. In my experience, setting it one way or the other has been known to make a difference.

Edit: on my Mac VMs, recently things have worked best if I assign static IP addresses to the VMs.

If you do use the private IP, you need to pick the same subnet in the settings for that debugger stub target.

Thanks everyone for your suggestions. @Jerry_Fritschle @Greg_O IPs (all same subnet) are DCHP assigned and then reserved, so yes, effectively static. Interestingly, rebooting the Pi VM (using VMWare on Win 10) doesn’t necessarily resolve the issue but rebooting the host PC seems to. @Julia_Truchsess thanks, helpful to know it’s probably not to do with my dev setup. Will try looking at traffic between Xojo and the debugger stub with Wireshark when I get time.

The Xojo Remote Debugger on macOS and WIndows does a lot of debug logging - I would assume the same is true on Linux OS - does anyone know where the linux log files are located?

tail -f /var/log/syslog

1 Like

Do you know where the Windows logs are located? Thinking they might have something useful to indicate why setup of a debug connection session to the Pi stub is failing.