Problem with PNG pictures on Windows

How to make a PNG image not crenellated / pixelated on Windows 10?

Here is the same PNG image drawn by DrawPicture in a Canvas :
on MacOS 10.14 :
on Windows 10 :

Is there a solution to improve rendering on Windows?

Xojo 2018r4 or 2019r11

First, you must take a look on your graphics file. Is ist a HiDPI picture? Then you must check your display settings. Has you Mac a Retina display? For Windows10 there is a problem if your system has 2 displays with different resolutions. If your Windows10 notebook has a HiDPI display and your external display is not a HiDPI display, the graphic looks different, if you move your application window from display 1 to display 2. Also you must check, if your display settings has a zoom factor of 100% or more.

It look like anti-aliasing is off, could you link the image so we can try it here?

If you are scaling the picture when drawing it could be that interpolation isn’t being used.

I would maybe also check to see if the PNG is interlaced. If it is try resaving it as non interlaced to see if that helps.

I use .PNGs routinely on Xojo and I don’t have this issue. Make sure the image is scaled outside of Xojo to what you want to use, and that it isn’t interlaced.

Here is the original PNG image

How do you see that it is interlaced or not?

The picture is resized in Xojo, because in this program we do not know how the user will display it.

Put this before the g.drawpicture

g.AntiAliasMode = Global.Graphics.AntiAliasModes.HighQuality

Additional info here

yes, it’s much better, thank you Julian !