Problem with Android Studio - VirtalDevice for Xojo

Hi, i am on an Intel Mac.

A few weeks ago i used the Android Studio install for XOJO Android build or RUN.
Then the virtual device startet and worked.
Now, with Mac OS 14.4 & the new 14.4.1 the Andriod QEMU (from Android Studio) doesn’t work any more - Virtual device starts but black screen content & / or after a few seconds QUEMU (part of Android Studio) crashes.
Has nothing to do with XOJO - also Android Studio Virt Emu startet from A Studio doesnt work anymore.

Tried updating A. Studuio but didnt helped.

Anyone has the same prob so wait for JAVA or Android Studio or furher 14.4.x updates?


1 Like

I had the same problem running xojo in windows.
Call the android Studio first with a simple project and run the application with an empty activity.
The virtual device appears and it works fine.
Close the android studio, only “android studio” and let the virtual device on screen.
When you run xojo app it will work, for some reason in windows xojo does not call the virtual device by itself, the black screen appears, but if the virtual device is already on screen it works fine.
It happens on windows, when i run on Mac Os , xojo calls the virtual device normally, the problem not occurs.

Thank you.
My problem on Mac OS is that even running only Android Studio with an empty project, the Virtual device crashes. So also XOJO cant use that virtual device.
Anyone here running Mac OS Version at least 14.4 and no crash (crash is in an Java .dylib ).

I read of bugs in 14.4 with Java. You need 14.4.1 for Java to be able to run.

If Xojo or Android Studio cannot start the Android VM, then I recommend deleting the Android VM from Android Studio and recreating it, after making sure you have all the latest Android Studio updates.

I made an short video about the fail of the Andriod Studio Emu, started by XOJO.
Android Emu fail…

I have installed latest Studio.

As i said in first post, its not a problem with XOJO itself.
Latest Android Studio seems to be the problem.
How does Andriod Studio communicate with its own emulator / or with XOJO?

I can see that there are some Network (lokal only?) connections established.
Can it be that here is an problem?
I show you what Network Monitor (LULU Firewall, all connections allowed) lists about connections and how many data bytes are transfered = ZERO?!
Looks this same to other users (running Mac OS 14.4.1, Intel Mac)

Below you see network if XOJO try to connect to the emulator (which has black screen, boot failed)

News about problem with Android Studio, QEMU running on INTEL+ Mac OS 14.4.1:
Now i installed olderStable Version (Nov 2023) and all is working again.

Reinstalled newest Studio = old Problem , not working!