Problem Creating Setup for my App with Inno Setup

Hi.
I practice building an app for serial communication which detects hardware devices connected to computer USB ports. The application works well on the Xojo IDE before it was built. However, when built, it doesn’t detect the devices connected even on my computer. I perfectly compiled it with Inno Setup wizard and installed to my computer and other computers, yet did not detect any of the connected devices. It was on windows. Kindly help me out. Thanks alot.

Unsure what this has to do with Inno.
Does it fail to install?
Does it fail to run once installed?

did not detect any of the connected devices.

What code do you use to ‘detect hardware devices’?
What error trapping do you have in place?
What error logs do you create, if any?

1 Like

maybe I’m wrong, but have you tried disabling the antivirus?

So, what does this has to do with the installer?

Does the application works as expected once COMPILED and before using inno?

Where do you install the app? Do your app writes to the installed location? If yes, it has the correct privileges to do it?

Thank you. Problem solved. I figured out that the problem was the USB cable. It’s now working well. Many thanks.

I mean the USB cable

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.