Printing report on Mac Yosemite 10.10.2

Hi. I just received a call from a customer who said she was unable to print a report from my application on her Mac. I use the Reports tool in Xojo. I tested on my Yosemite 10.10.2 while on the phone with her and received the same error as she did:

[quote]This application is not allowed to print.
Please contact your application vendor for an update[/quote]

I then tried on my older Mac running OS X 10.7.5, and it printed no problem. Not sure what version of Mac she has. Just sent her an email to check.

Is there a workaround to get reports to print on Yosemite?

Is your app signed ?

Yes, I use AppWrapper to wrap and sign the apps

The apps run just fine without any issues. This was the first I’ve heard from a customer with a printing error, so it prompted me to look into it

Sam mentions printing in the blog post and what to do

Ah great! I will give this a try. Thanks Norman!

Are you Sandboxing the application? If so, select the “Printer” checkbox, under “Hardware Access” of the “Capabilities” pane.

That did the trick! Thanks all!