Preview doesn't open PDF anymore


i know this is no Xojo-specific question. But here are some mac-users, so why not.

I have a problem with OS X It does not open any! PDF-File. The Problem occurred 1 or 2 days ago. I wondered, that my PDF-Files had a Safari-icon, and so they where opened in Safari when clicking on them. I tried to switch back to Preview (getting -> open with…) but OS X does not show Preview in the list of reccomended apps. So i clicked on “all apps” and choose Preview as standard for all PDF. The Problem was still there.

So i created a new user, there i did not face the problem. Ok, made a new account for my main-user and everything worked fine… for a short time. Then, suddenly, the error was back again. I do not know, if a special app breaks this, but also after installing a complete fresh Yosemite after formatting my disk, the error came back after a few hours. Maybe caused by an app-installation, don’t know.

Has anyone faced this problem before and knows how to get rid of it?

search preview pdf

Can’t believe this… costs me days.

Thanks Peter.