Postgresql password

I installed (I think) Postgresql (actually a few times) and when I run pgAdmin it asks for a password. NOT a clue!

This macbook pro ran without a USER PASSWORD, So I set one. Then I uninstalled postgressql, and reinstalled.

Still asks for a password, mine doesn’t work? How can I either change or set the password?

Or WHAT?

The initial password for the default postgres user is usually blank. Try that.

And then change it as soon as possible to something secure.

I TRIED BLANK! Nada. I mucked something up. SOP for me. Maybe I should try bowling…

You could try “postgres” for the password also, or even “password”. If those don’t work, then try this guide for resetting it (additional tips here).

Wouldn’t you think uninstalling, then re-installing would reset the password?
Hidden files?

I’m not sure about PostgreSQL, but many apps don’t remove configuration and/or data files when uninstalled. You could search for postgres folders after the uninstall.

Oh, also, did you uninstall the postgresql server or just pgadmin?

Have you tried “admin”? Usually, there is a default password. Valentina has “sa” for instance.

It looked like when I uninstalled postgreSQL it also uninstalled pgAdmin. But the files leftover probably is my problem. Some settings that I made were still the same after I uninstalled and re-installed.

I will un-install both again, and then see if I can find(??) the left over files.

If that fails, I think I will try this on my Windoze computer…

Use “Find any File” from Thomas Tempelmann. Perhaps there are some plist files left over.

Have you checked the Keychain?

I will get “Find any File”. Thanks.

The Keychain? How do you check that?

The places to look for leftover files are:
~/ (your user folder - should be a PostgreSQL folder there)
~/Library/Application Support
~/Library/Preferences
and of course the Applications folder.

You shouldn’t need to worry about the Keychain.

I create the first user and database via PSQL then use PgAdmin forever after that. Use PgAdmin on the PostgreSQL machine to allow remote access to the database too.

Using “find any file” I moved the left over files to the trash, then re-installed and guess what? This time I was asked to enter the password to use with the server. NOW pgAdmin works…

Thanks to all for the great help. Best Forum I’ve ever used!