Plugins code-signing drama

Ok so a while ago I had problem with bad code signature where I thought Yosemite zip compression was the issue but Joe found it was the code signature.

The fix then was to flip codesign off, Clean, Rebuild - codesign back on - build - repeat 2-3 times. (Fixed for no known good reason).

Now I got same problem with other plugin, except I am having little luck getting it to be all right, I sometimes get the Bundle to work but only sometimes, never the xojo_plugin (not even from same build where the bundle worked).

Running codesign -dvvv in terminal on the file shows its code signed.

How do I diagnose those things ? Am getting a bit stuck in this, and its awful solution to have to try and compile again and again until its ok when this happens.


Error messages?

My MBS Plugins ship signed with my certificate.

You can overwrite that with yours if you code sign your app. No problems so far.

Just that Xojo thinks its not code signed:

/private/var/folders/fp/6r9jvhtx4rx1c73z29yqjw3r0000gn/T/pluginbridge.DUuzYE: code signature invalid for '/private/var/folders/fp/6r9jvhtx4rx1c73z29yqjw3r0000gn/T/pluginbridge.DUuzYE'

Nov 18 21:52:27 MiniMac.vodafone Xojo[11273] : [RB] Unable to load plugin CalendarControl.xojo_plugin

Running codesign -dvvv on the bundle though shows that it is signed

I don’t know whats up and why it happens to just this plugin now and once some weeks ago

do you see that message also for my plugins? If not, we could figure out what you do different.

I just call codesign for my plugins:
codesign -f -s “Mac Developer: Christian Schmitz” -i MBSCFNetwork.dylib MBSCFNetwork.signed.dylib

and the certificate is valid of course.

No I don’t in generally see this message on my plugins, it started happening after I upgraded to Yosemite then had it on one plugin at first, then didn’t see it for a while until now when I get the 2nd plugin that suffers from this.

Well the plot thickens and I am even more lost in what is happening:

  1. I rebuild the plugin.
  2. I try to just run the CalendarControl.xojo_plugin (Fail)
  3. I try to run the dylib from inside the Bundle straight from the build folder (Fail)
  4. I run the bundle that contains the dylib from the build folder b[/b]
  5. I repeat step number 2, and it works now on CalendarControl.xojo_plugin (having removed the bundle of course)

I repeated this 3 times, to verify the results, always the same.

Since it can run it from the bundle then I think its safe to say the code signature is definitely all right.

I imagine something gets cached when running it once from the Bundle that then makes it step over some step when trying again from the dylib or from the CalendarControl.xojo_plugin. But in any case I am stuck since I imagine users would get same issue.