Plugin not loading

I have an Einhugur plugin called PDF Plugin, it is an older one from 2016 but ok for my needs.

It has been loading correctly since now, both in Windows and in Mac. In Windows it still works fine but in Mac it won’t load at Xojo start.

I have tried to only keep this plugin in the folder, resetting permissions, correcting translocation (I read this could help), getting the file from my Windows, etc but it simply doesn’t loads (no messages, no errors).
It fails in Xojo 2017 R3, 2018 R1 and 2018 R2.

I believe it doesn’t works since Mojave upgrade but all other plugins work fine.

I would appreciate any help.

Update: Console shows message “[XOJO] Unable to load plugin PDF Plugin.xojo_plugin”

Does that version of the plugin include 64 bit support?
It could be that the Mac Xojo IDE you are using is 64 bit so requires the plugin to contain a 64 bit code segment to load.

The plugin may have dependencies.
Did you install the base plugins from Einhugur? #Type or how it’s named…

Looking at the version history then this plugin probably always had 64 bit support.

So best bet might be what Christian suggests to check if you installed #TypeLib. And I imagine it would need to be the TypeLib that was valid at whatever time your plugin version is from.

Though there is no guaranty that old version will work with newer Xojo, a number of things always change over time. But I think you should be able to at least I cant think of a reason why you should not.

Yes, I have made sure that #typelib and #typelibf are loaded.

It should support 64bits because I’m compiling fine in Windows for 64 bits target and with Xojo 64bits.

What I don’t understand is that version 2017 and 2018 R1 doesn’t load it now regarding it has worked fine before.

I will now try to install Xojo in El Capitn, discarding OS problems.

Ok, I have started El Capitn and copied the Xojo 2018 R2 folder from my Mojave drive into Applications. Started Xojo from there and it works fine, the plugin is loaded and shown at the About window.

Started again Mojave and tried Xojo from El Capitn drive, it does NOT load. Also started from Mojave applications and it neither loads.

It seems Mojave doesn’t like it ;(

Btw, regarding the issues I had with Mojave in a USB SSD drive (very slow boot and performance) I have changed file system from APFS to HFS, it works far better now (sytem not plugin). Before this change I tested the plugin and it doesn’t loaded.

What happens if you grab the demo from our web of latest ? On Mojave that is…

I cannot think of any reason why non GUI plugin would work on El Capitan and not Mojave. Maybe some sort of codesigning issue but it seems far fetched.


thanks. Yes, this seems to work, the new version loads. I have also updated Xojo to R3 but old plugin didn’t loaded.

Probably something on the signature as you mention, Mojave has not been a pleasant upgrade until now :frowning:

Time to upgrade my plugin, I have already send you an email.