Please turn off AutoQuit for the Windows IDE

46896 - Please turn off AutoQuit for the Windows IDE
Michel Bujardet Today at 2:41 PM

The Windows IDE takes forever to load. It would be nice if it behaved like the Mac one, which does not quit when closing a unique project, so loading a new project takes much less time.

It is still possible to quit when no project is loaded with Right Click/Close Window on the taskbar icon.

feedback://showreport?report_id=46896

I guess this is the way Windows works: When last window for an application is closed, the application itself closes.

If autoquit is explicitly set to false in App.Open, the app no longer quits when the last window is closed.

Given the very significant time it takes for the Windows IDE to load, such a feature would be a great time saver.

[quote=314321:@Michel Bujardet]If autoquit is explicitly set to false in App.Open, the app no longer quits when the last window is closed.

Given the very significant time it takes for the Windows IDE to load, such a feature would be a great time saver.[/quote]

True, but the application remains a zombie, due nothing is shown. They might probably open again the dialog for creating a new project…

Is this request different than what is provided by the “When closing last window” General Preference in Windows is set to “Keep Xojo running”?

Actually, this is not the way Windows works. You can open programs without opening any working file. By working file I mean - spreadsheet for Excel, document for Word, project for VB6, etc. In other words, you can open Excel, Word, VB6, etc empty and ready for whatever you want to do - start new file or open existing file. When you close the working file, the program remains open.

I am unable to figure out what that setting does. Can I close a project without closing the IDE? How can I also open the IDE empty? It will be nice to be able to keep the IDE opened empty during the work day.

The IDE stays open, but no windows are shown. This saves on load time if you open a project. Much like using the IDE on Mac.

I was going to say the same thing. That is exactly what I use that preference setting for.

From the User Guide:

[quote]When closing last window
This setting is only available on Windows.
When “Keep Xojo running” is selected, a new icon appears in the Taskbar Notifications area (also known as the System Tray) and Xojo remains running when you close the last Workspace window (instead of quitting). You can right-click on the Notification icon to display a menu with “New Project”, “About Xojo” and “Exit”. “New Project” opens the Project Chooser window, “About Xojo” displays the About window and “Exit” quits Xojo completely.[/quote]

Nice :smiley:

It looks as if it is closed but when you go to relaunch Xojo it loads instantly. Task Manager will show it remains open.

Thanks.

No wonder I cannot get my head around this. Clicking on Close [X] control button is not the same as File-Exit. Not finding a Close Project in the File menu. And my Notification Area (system tray) is set not to “Always show all icons and notifications on the taskbar” (which is the default if I remember correctly) in the Taskbar and Start Menu Properties settings so I never get to see the Xojo icon there.

@Michel Bujardet - maybe you can modify the FR so the icon is visible on the taskbar. It used to be, but apparently not anymore.

The icon shows in the system tray, but only after you have set the option and restarted the IDE.

The icon does show in the system tray, although you may have to tell Windows to show it. This is Windows 10:

This is why I love to read User’s Guides.

This is why everybody have to read User’s Guides.

But, hey, this is a free country :wink:

Now, if we could just get that in Linux :stuck_out_tongue:

That is exactly what I was after. Thank you.

But yet, why is the default behavior of the IDE opposite in Mac and Windows ?

Indeed, the icon no longer shows when there is no window.

Default windows behavior groups application icons in the System Tray, but you can change that behavior by contextual clicking the system tray, choosing settings and down the bottom in the Notification area is a hotlink to “Select which icons appear on the taskbar”. In there you can set the option to always show all icons which stops that grouping behavior or you can just switch on the xojo application, but this will need to be done for each version.