Pigpiod gets killed on Raspberry Pi3+, but OK with Pi4B

In a minimal program, in the Window1.Open:

...
pi = New pigpio
Call pi.gpioInitialise()

Here pigpiod got killed on Pi3+ (but is OK on Pi4B).
Happens every time.
Did sudo killall pigpiod followed by sudo pigpiod.
Any pointer welcome.

I use the latest of ‘everything’, I think.
Like pigpio and pigpio(7Jan2021).xojo_binary_code
Buster, Xojo 2021r1.1
Did not do the ‘sudo rpi-update’, though. (Scared, I’m 6 time zones away from the hardware)

Hello @Lennart_Ramberg,

I just installed the 32-bit Raspberry Pi OS (32-bit) and compiled the ARM-32 example 5-2 in the book to successfully turn on and off the LED light with Raspberry Pi 3 B.

Here is the quickstart steps that I used to have it working:
• Install Imager and follow directions (make sure to install 32-bit of Raspberry Pi OS)
• Check for 32-bit with ‘uname -m’. If is reports back aarch64 its 64-bit, if is says armv7l then its 32-bit. 32-bit Raspberry Pi OS is needed for Xojo 2020 r2.1.
• Raspberry Pi OS is now installed
• sudo apt-get update //(This updates the install files)
• sudo apt-get upgrade //(This command performs updates on apps)
• sudo apt-get dist-upgrade //Updates the OS distribution
• sudo rpi-update //Updates the firmware
• Reboot needed
• Install library (sudo apt-get install libunwind8) (should be installed)
• The pigpio is automatically installed and is bundled with the Raspbian Operating System
• Run the command ‘sudo systemctl enable pigpiod’ to start the daemon after rebooting
• Run ‘sudo systemctl daemon-reload’ to reload the boot programs
• Check to make sure it works with ‘sudo systemctl status pigpiod’ (press Ctrl-C to finish reading the complete script on the terminal)
• Download Eugene’s free library at Github: GitHub - eugenedakin/pigpio-GPIO: Code for Xojo apps to access the Raspberry Pi GPIO pins through the pigpio library
• Drag and Drop the class into your project
• Add an LED and resistor to Pin #1
• Compile Example5-2
• sudo chmod +x Example5-2
• sudo ./Example5-2

1 Like

Thanks Eugene,

Mea culpa! I should have mentioned that I run the Pi3+ remotely using TeamViewer,
so I only used the GUI to launch the program.

Running as an ordinary user will kill pigpiod.
Starting the program via TeamViewer I had to (with pigpiod running):
Right click > Open with … > Custom Command Line > sudo %f > OK

It works. The behaviour doesn’t feel consistent though and,
admittedly, I’m still a bit confused, but that is perhaps another story …

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.