Pictures show in IDE but not when run

Hello all,

I don’t know if this is Linux specific, anyway that’s the platform I am running. To make it short:

  • I run 2019r1.1 on Linux Mint 18
  • I am attempting to “convert” an older (>10 years old) 32bit app written in RealBasic to a 64bit in Xojo.

My present problem is that I have three pictures (available as jpg, two as canvas backdrops and one as ImageWell image) that show perfectly in the IDE but won’t show if I test the program with “run”.

I’ve read something about “resource directory”, I’ve dragged-dropped the directory on the project, no use. I’ve tried the “convert to image” option - such converted pictures crash the program. I must be missing something: what should I do to get an image to appear on a canvas or an ImageWell?


Hi Thierry.

I recommend that you convert all of your images to PNG format and re-add them to the project. Install the “imagemagick” package and then use the “convert” command to convert the file:

convert filename.jpg filename.png
As an aside, I would also recommend that you do the update in steps. I load and “Save As” in 2016r3 and then again in 2018r1.1 to move old projects forward and that works very well.

Hi Tim,

Converting and re-adding did not change: the pictures appear in the IDE but not when running.
I’ll take a look at installing 2016r3. Thanks.


How do you work with the images ?
ie: how do you go from the images in the Navigator to the images in the Canvas ?

What error do you get at compile time ?

Did you clicked in the right button above the code editor (I do not know its name, but it checks the syntax, unused Variables, Events… and many other things), it is in the group of icons like Set/Unset Comments…

The use of g does not works anymore outside of the Paint event. It is noted as deprecated in the most recent Xojo versions.

Check the Release Notes and read the page about it.

Hello Emile,

First: I have opened and run the very same code in the Mac edition and there everything works as expected. I have saved the project, copied the whole directory back to Linux and the pictures simply disappear at run.

As to the images, as I said I first tried to assign them as properties of the canvas or the ImageWell. Then I tried to drag ans drop a folder containing the pictures on the project, as I had found in another discussion.

At run time I get no error. The program works, simply all the pictures are gone (empty spaces).

As I said first: my code works on the Mac (at least in debug). Only Linux has problems. However I’m not sure I would buy the more expensive version only to be able to compile one app for Linux…

Can you provide a simple demo project showing the problem and an image all in a zip file so we can test it?

OK, so when I start a new project the picture show…

I guess I better rebuild my app from scratch, copying the code over. There must be something corrupted somewhere.

Try saving it as a binary project and then reloading THAT project. Does the issue go away?

I suppose you build a Desktop application (and not a Console application).

Alternate suggestion:
Build a simple project who only display (both: dropped in the project and loaded from disk) some images (png). Run it either in the IDE AND as a Stand Alone.

If the above works, compare the code in this project to what you’ve done in the other one.

Doh: can you share the lines of code you use to display an image ?
(and the type of images: png, jpg,tiff, hiec [heic ?], webp, etc.)