Picture.Open WMF


In Xojo 2016r3, Picture.Open a WMF file gives the picture
In Xojo 2016r4.1, Picture.Open a WMF file gives NIL

why ?


I don’t see anything about WMF, so it might have been sheer luck that it worked to begin with.
The major difference between 2016r3 and 2016r4 is the switch from GDI+ to Direct2D

Edit: Okay, I found on the main page of Picture that WMF was supported, but there was also this note:

So it may have not made it through when they switched from GDI+

File a feedback report?

What do you want to do with WMF?

Our DynaPDF plugin can convert WMF to PDF.

PS: or you can write little app in Xojo 2016r3 to convert to PNG.

I just want to print the wmf picture…
And App.UseGDIPlus is always false in this project

Christian your plugin can read a wmf file to get a picture ?

Let me check tomorrow. Maybe grsphicsmagick plugin does it already.

tomorrow never knows :slight_smile:

Is it FALSE, because you need it to be?
or because you never set it to TRUE?

App.UseGDIPlus is false, because I tried true, but the result on all the graphics displayed was catastrophic.
Then it remained false, and it did not prevent me to read WMF…