OS error message

[quote]6/24/2014 9:22:28.850 PM RVCare Log Book.debug[715]: view service marshal for <NSRemoteView: 0xc151a30> failed to forget accessibility connection due to Error Domain=NSCocoaErrorDomain Code=4099 “Couldn’t communicate with a helper application.” (The connection was invalidated from this process.) UserInfo=0xd447f40 {NSDebugDescription=The connection was invalidated from this process.}
timestamp: 21:22:28.850 Tuesday 24 June 2014
process/thread/queue: RVCare Log Book.debug (715) / 0xb0093000 / com.apple.NSXPCConnection.user.endpoint
code: line 2972 of /SourceCache/ViewBridge/ViewBridge-46.2/NSRemoteView.m in __57-[NSRemoteView viewServiceMarshalProxy:withErrorHandler:]_block_invoke
domain: communications-failure[/quote]

I’m trying to ‘sandbox’ test my application and I get the above message. Have tried to goggle it and can’t find much. I’m using OSX 10.9.3 running the debugger and Mini App Wrapper to make it sandbox.

I this a problem or should I just ignore it?

Do you have a helper application? If so, how are you communicating with it?

No helper application.

Could it he a plugin? I’m using some MBS stuff.

I Googled it a bit and saw some references to file dialogs creating similar errors in the sandbox. Try opening Console.app and see when the message is posted. Is it at launch or when you do a specific action in the app?

The system message is produced after routine containing “f.Launch” (where f = folderitem); goes back to system event loop.

I guess I need to find replacement for the f.Launch.

This is BAD. If I had not been looking at the log I would have thought my application was ok, the document that was Launch was a .PDF and was opened in Preview.

Just to see what would happen if NOT sandboxed I ran and did the same things, NOT message.

You could try using the “open” command from a shel and see if you still see the error, though I don’t think the message is anything to panic about. As far as I can tell it seems to be an Apple bug, not your issue… (but you’ll maybe get complaints from users still)

try something like

dim sh as new shell sh.execute("open -a Preview.app "+f.shellPath)

See if you still get the error.

Tried the above. Got same message. Think I just ignore it.

Thanks guys.

shell to open

What are you launching, a document or a application? There are APIs for both.

This file, is it a file you have access to?

It a .pdf and user has just selected enclosing folder. I want the user’s default app to open it. And It does open ok in Preview, I just get and error message in syslog.

You might try doing the shell command I mentioned without the app specifier ie “open [path to the file]”. I’m assuming you have the “User selected files” entitlement selected…?

Jim,
Yes. Using the shell = same result.

Are all of your frameworks signed with the same signature?
Try
codesign --verify --verbose=4 [path to your app]

(then I’m out of ideas here)

All verify.

Thanks for you effort.

Ha! I’ve already logged this, it’s to do with the Open dialog. Stupid me… Sorry for dragging this out longer than needed to be.

feedback://showreport?report_id=34046