Option+Drag when DragReorderRows in Listbox

I see that if you have EnableDragReorder enabled on a Listbox, if you drag a row (or rows), they move to their new location.
When you press the Option key while dragging, a “+” shows up. I thought, Cool! I can copy rows this way! No such luck. It seems the “+” indicates nothing, it just moves the rows as before. Not sure why the icon changes if the functionality doesn’t…

Without completely re-writing the drag reorder function, is there a way to copy and move rows as well as just move rows?
I tried some things in the DragReorderRows Event, but doing anything to the table seems to cancel out the moving of the rows (even when returning false)…

Yes it is, you have to write the code to do it.

Look at DragItem in the LR. (I think)


Not to worry, I was able to do it. Not pretty, but it works with single and multiple rows and even with non-contiguous selected Rows!

Such a kludge to have to use a timer in the DragReorderRows Event to emulate a DragReorderRowsComplete Event which should really exist on it own, but there ya go…

Ah, Language Reference.

Is the DragItem populated when using DragReorderRows?

So I have the option+drag working properly to copy rows in my listbox.

In MacOS, the mouse automatically changes to a green circle with a + in it, indicating a copy-drag. Awesome.
In Windows, though, the mouse does NOT change. Is this a Bug in the Xojo listbox code or something else?
I cannot figure out any way to manually change the mouse cursor when drag reordering rows in Windows, even if I were to try to override it.

You do not disclose what you tried, so, did you checked:
System.Cursors ?

Yes, I tried plenty of things, short of declares.


So this is a Bug or need a Feature request.