openSUSE: installation: shared folder ?

I installed openSUSE (openSUSE-Leap-42.2-DVD-x86_64.iso) in the latest VirtualBox.

I created my shared folder in my MacBook Pro hard disk (beside the shared folder for Windows).

To be sure, I installed the latest Guest Extension (Oracle_VM_VirtualBox_Extension_Pack-5.1.22-115126.vbox-extpack) in case I forgot to do it earlier.

I boot on Linux, do the install: no shared folder.

I quit, boot, run Linux: no shared folder.

I searched in the documentation (pdf), online, etc. Nothing.

I read something about /media (and as usual, they do not say where it is ! (in root I suppose, I get Racine in French).

I open the /media folder and found if empty.

Help ?

How can I achieve my goal ?
(I was even not able to download Xojo from the web site, go figure).

Creating a shared folder

Create a folder on the Host computer (Mac) that you would like to share, for example ~/myshare

Boot the Guest operating system in VirtualBox.

Select Devices -> Shared Folders...
Choose the 'Add' button.

Select ~/myshare
Optionally select the 'Make permanent' option

Hi Thomas,

thank you for your answer.

Already done. Saw nothing.
Screen was in 1280 x 900 mode or so. I also wear my glasses, but I still saw nothing (shared folder works fine on WIndows).
The shared folder is meant to be in Root:Media
Cleared that VM.

Drag and drop does not works too (but Clipboard <–> works) for both Linux.

Fired Linux Mint 18.1 (64Bits ! Xojo 2015r1 applications).
I do not see the shared folder either
Tried Firefox: works.
Upload my files (Application and a bunch of files to deal with that application), from the macOS host,
Download the zips, csv, whatever.

Found a bunch of bugs (specific to Linux: works fine on macOS / Windows *)

Squashed all bugs found excepted one:

I use Keyboard.AsyncOptionKey: nothing happens where it works on other OS.
I added Or Keyboard.ControlOptionKey: nothing happens too.
Used code:

If Keyboard.AsyncOptionKey Or Keyboard.AsyncAltKey Then

A bit boring to upload/download the files for testing.

Worst: I have to re-download if I quit VirtualBox. Installing Mint ask more than 10GB… (it seems that I used Mint as Live CD…)

At last: Mint is slow as hell. Click twice to launch the application, smoke a cigarette and when done, drink a cup of coffe, then the application appears on screen !

Problems: I do not smoke and do not drik coffee at home / expensive at McDonald’s (a bunch of coffees…) and produce strange results on me: irritability, trembling, etc. :wink:

Back home, I will clear this Mint install and add a brand new one with 20MB.

My main HD (boot device) is a 250GB SSD.

  • My fault for some.

Problem with the VM could be that you started it in ‘live mode’. So there’s no standard user and only a rudimentary root user is used for login. So your host and the shared folder uses different permission settings that your guest system can’t bring in. I use a special standard user ‘vmuser’ which is in group ‘vboxsf’ on my host and any guest machine. Works fine for me. With Linux Mint 17+, ElementaryOS 0.3+ and Ubuntu 12.04+, different flavours each, 32- and 64-bit.

But I haven’t tested your problem with AsyncKeys.

BTW: Speed is best with Linux Mint XFCE as guest os, other DMs as Cinnamon, KDE, Unity aso. give me lag as h$ll

Hi Thomas,

I deleted the Live CD virtual machine. I took time to install a real virtual machine.

I still do not have a shared folder (I have a doubt right now. I will check later I have to go now).

Even MemoryStick (FAT32) is not seen. The /media folder is empty.

If I quit Firefox in the macOS host, the speed start to be standerd (i3 processor @ 2.6GHz here).

I use a MediaFire folder as a temporary folder (to upload / download data between host / cirtual machine)… but this takes time.

Someone takes the URL of the folder I use (I share this URL in my Resumé at my local Agentur für arbeit [Pôle emploi] web site) and download 12 times (or 13 ?) a 434MB zip (and a csv file about this archive)… These are just Tarzan Sunday Strips from 1931-1934, so nothing confidential or so. But the steal happens the day I started to share data there ! Absolutely strange coincidence if any ;).

About the Keyboard key:
I used the shift key (in a #If TargetLinux block) for Linux and it now works !
I have to change that part of code and set the shift key for all platforms (but I loved to use the alt key !).

Thanks Thomas.


Just Tested it in my openSUSE VM (KDE-Desktop)

Shared Folder “VM-Data-Sync” was created with “Auto-Mount” and “Make Permanent”

mounted under Root:


Via Dolphin - Filemanager: “Root-Folder” or simply “Root” -> “media” -> “sf_VM-Data-Sync” (Im on a German System where it’s “Basisordner” so im not sure about the Englisch Name for Root Folder)

@RenLandscheidt : signed

Now I had time to test it with OpenSuSE 42.2 as a guest system too. Same result here. My shared ‘downloads’ folder in my home folder on the host system is mapped to /media/sf_downloads in my guest OS. Permissions OK too (rwx). But OpenSuSE not that fast for me with KDE.