Once again - Internal Server Error on Web Apps

Dear folks,
may I ask you for some help on an “old” topic - tried figuring out with a lot of articles and blog entries, however I didn’t figure out what causes the experience…
So what I’ve got as baseline is a Apache web server on an Ubuntu VPS hosted by HostEurope Germany. Works pretty smooth, so good so far.

That’s the situation:
I have the example XojoTest.cgi demo uploaded onto my server, for Linux as CGI, running on port 8081 - works fine in /cgi-bin/XojoTest/xojotest.cgi…
I have a simple own-created web app uploaded into a second folder, compiled for Linux, CGI-Version, Port 8080, it’s own App identifier, loaded into /cgi-bin/photos/pjergeb.cgi - all it does is ending up with Internal Server error…

What I have tested already:

  • ensured that the CGI / all libs and the Perl Script are CHMOD 775, config.cfg both tried with 666 and 775 (as found on the web), webapp folder itself is 777 for test
  • reviewed the error.log of the webserver; all it says is “Premature end of script headers: pjergeb.cgi”, no further information
  • ensured that .htaccess is uploaded
  • ensured that everything is uploaded as binary transmission, not text transmission.
  • reviewed other logs of the server - nothing entered there.
  • tried to compile the app in 2014.r1 instead of 2015.r2.4, same result

When running in the IDE on my local mac, it works fine; and I had it once to at least say “launching” with “cannot connect to web app”, right before I set app.autoquit to false.

What I’ve seen is that there are a bunch of core.xxxxx files when I open up the URL of my own script for a couple of times, so it seeeeems to do something, however the browser always displays the 500 internal server error with no further information. Still, when trying the other link to the XojoTest CGI, this always works fine and creates a lot of entries in the access.log of the server, however my own CGI just shows a get request with a 500 status code.

So I’m close to the end of my ideas - can you help me ? Someone in experience with the HostEurope VPS environment regarding the Xojo Web Apps ?

Thank you in advance,

Is your server using a 32 or 64 bit OS? If it’s 64-bit, do you have the 32-bit compatibility libs installed?

Also, leave the port setting on Auto for CGI apps. You’ll have a much better experience.

Greg, that’s a good question… I assume it’s 64bit but will have to check.
Hey, one thing that worries me - if I compile the app for CGI I get the internal server error, however if I compile the same application for standalone execution and put it on exactly the same server bypassing Apache, it works smooth as standalone app…
I assume, don’t really know - if it would 64 bit OS missing the compatibility libs, it shouldn’t run as a standalone too ?
Will switch it back to auto port selection, makes sense (as it’s internal ports not passing the FW)…

If the standalone runs on the server it means the CGI should as well.

If setting the port on Auto does not work, what is the exact error you get with the CGI ?

Did you check that the ownner/group for all files is the user/group running the apache (web) server?