Office Automation plugin crashes 2017r2 IDE on load

I just installed v2017r2, initial launch was OK.
Then I added MSOfficeAutomation.rbx to the Plugins folder and the IDE crashed on the plugin load phase.
When I remove the plugin, it loads properly again. When I put it back, it starts crashing again.
This is the first version I’m encountering such issue. Has anyone come across this?
I’m on Windows 8.1 64bit.

You did use the one that came with 2017r2 ?

I’ve just tried Windows 7, 8.1 and 10 with 2017r2 and its office automation plugins and havent had any issues

yes, I’ve used the right one.
this one:
// File Checksum Integrity Verifier version 2.05.
95c4965d4b2e9371faa8b28fd21168a2 msofficeautomation.rbx

[quote=347688:@George Poulopoulos]This is the first version I’m encountering such issue. Has anyone come across this?
I’m on Windows 8.1 64bit.[/quote]
I picked 5 Excel examples and they all seem to work on Windows 10 running Xojo 2017 r2.

re-downloaded setup file from the site, just now.
installed fresh at a different pc where 2017r2 had never been installed (also W8.1_64)
exact same issue: crash at IDE startup when the office automation plugin is present in the plugins folder.
on the same machine , 2015r2.4 and 2017r1.1 live happily without any problems of that sort.

did the same at a third machine, this time a windows7_64 at work.
exact same problem: 2017r2 crashes while 2015r2.4 is perfectly fine.

I don’t know what to think anymore…
are we all using the same thing?
MS File Checksum Integrity Verifier version 2.05 says:
7bd46fa616697930c6103d1e32c3c28a xojo2017r2setup.exe
303c838f5f02b3957c926a26aa0b21f1 xojo.exe

No idea
I’ve run it the IDE on several machines set up seemingly “the same”

OK, that was good thinking!
I did look at the output of Debugview and saw a series of monstrosities that follow.
Then I thought: what makes me such a freak of nature?
and the first thing I tried was changing the Windows setting for Non-Unicode programs from Greek(Greece) to English(United States) in control panel’s Regional Settings.
And it worked! 2017r2 loaded fine!

The only problem is that I cannot keep that setting in English. And I cannot stop using Office Automation.
Whatever change was made in 2017r2 that is affected by this, needs to be reversed as everything was working fine prior to this release.

Shall I file a bug report or all that will suffice?

DebugView sample output (there were more of the same kind, I hope you get the point):

[2928] Unknown type: wdArtTreestypeInt [defnStrn[9flagInt [EndGInt 8CnstGrupT9EncoInt [nameStrnwdArtPalmsColortypeInt [defnStrn]10flagInt [EndGInt 9CnstGrupX:EncoInt [nameStrnwdArtBalloons3ColorstypeInt [defnStrn]11flagInt [EndGInt :CnstGrupX;EncoInt [nameStrnwdArtBalloonsHotAirtypeInt [defnStrn]12flagInt [EndGInt ;CnstGrupT<EncoInt [nameStrnwdArtPartyFavortypeInt [defnStrn]13flagInt [EndGInt <CnstGrup\

[2928] Unknown type: xlShowPercenttypeInt [defnStrn[3flagInt [EndGInt ;CnstGrupP<EncoInt [nameStrnxlShowValuetypeInt [defnStrn[2flagInt [EndGInt <CnstGrupP

[2928] Unknown type: xlFillWithAlltypeInt [defnStrn-4104flagInt [EndGInt ;CnstGrupX<EncoInt [nameStrnxlFillWithContentstypeInt [defnStrn[2flagInt [EndGInt <CnstGrup\

[2928] Unknown type: xlNoSelectiontypeInt [defnStrn-4142flagInt [EndGInt ’CnstGrupX(EncoInt [nameStrnxlValidateInputOnlytypeInt [defnStrn[0flagInt [EndGInt (CnstGrup\)EncoInt [nameStrnxlValidateWholeNumbertypeInt [defnStrn[1flagInt [EndGInt )CnstGrupXEncoInt [nameStrnxlValidateDecimaltypeInt [defnStrn[2flagInt [EndGInt CnstGrupT+EncoInt [nameStrnxlValidateListtypeInt [defnStrn[3flagInt [EndGInt +CnstGrupT,EncoInt [nameStrnxlValidatedDatetypeInt [defnStrn[4flagInt [EndGInt ,CnstGrupT-EncoInt [nameStrnxlValidateTimetypeInt [defnStrn[5flagInt [EndGInt -CnstGrupX.EncoInt [nameStrnxlValidateTextLengthtypeInt [defnStrn[6flagInt [EndGInt .CnstGrupT/EncoInt [nameStrnxlValidateCustomtypeInt [defnStrn[7flagInt [EndGInt /CnstGrupX0EncoInt [nameStrnxlIMEModeNoControltypeInt [defnStrn[0flagInt [EndGInt 0CnstGrupP1EncoInt [nameStrnxlIMEModeOntypeInt [defnStrn[1flagInt [EndGInt 1CnstGrupP2EncoInt [nameStrnxlIMEModeOfftypeInt [defnStrn[2flagInt [EndGInt 2CnstGrupT3EncoInt [nameStrnxlIMEModeDisabletypeInt [defnStrn[3flagInt [EndGInt 3CnstGrupX4EncoInt [nameStrnxlIMEModeHiraganatypeInt [defnStrn[4flagInt [EndGInt 4CnstGrupX5EncoInt [nameStrnxlIMEModeKatakanatypeInt [defnStrn[5flagInt [EndGInt 5CnstGrup\6EncoInt [nameStrnxlIMEModeKatakanaHalftypeInt [defnStrn[6flagInt [EndGInt 6CnstGrupX7EncoInt [nameStrnxlIMEModeAlphaFulltypeInt [defnStrn[7flagInt [EndGInt 7CnstGrupT8EncoInt [nameStrnxlIMEModeAlphatypeInt [defnStrn[8flagInt [EndGInt 8CnstGrupX9EncoInt [nameStrnxlIMEModeHangulFulltypeInt [defnStrn[9flagInt [EndGInt 9CnstGrupT:EncoInt [nameStrnxlIMEModeHangultypeInt [defnStrn]10flagInt [EndGInt :CnstGrupT;EncoInt [nameStrnxlValidAlertStoptypeInt [defnStrn[1flagInt [EndGInt ;CnstGrupX<EncoInt [nameStrnxlValidAlertWarningtypeInt [defnStrn[2flagInt [EndGInt <CnstGrup\

[2928] Unknown type: xlDialogParsetypeInt [defnStrn]91flagInt [EndGInt <CnstGrupT

[2928] Unknown type: xlOrConditiontypeInt [defnStrn[2flagInt [EndGInt <CnstGrupT

[2928] Unknown type: ppAlertTypeOKtypeInt [defnStrn[0flagInt [EndGInt *CnstGrupX+EncoInt [nameStrnppAlertTypeOKCANCELtypeInt [defnStrn[1flagInt [EndGInt +CnstGrupT,EncoInt [nameStrnppAlertTypeYESNOtypeInt [defnStrn[2flagInt [EndGInt ,CnstGrup\-EncoInt [nameStrnppAlertTypeYESNOCANCELtypeInt [defnStrn[3flagInt [EndGInt -CnstGrup\.EncoInt [nameStrnppAlertTypeBACKNEXTCLOSEtypeInt [defnStrn[4flagInt [EndGInt .CnstGrup\/EncoInt [nameStrnppAlertTypeRETRYCANCELtypeInt [defnStrn[5flagInt [EndGInt /CnstGrup`0EncoInt [nameStrneppAlertTypeABORTRETRYIGNOREtypeInt [defnStrn[6flagInt [EndGInt 0CnstGrupX1EncoInt [nameStrnppAlertButtonCLOSEtypeInt [defnStrn[0flagInt [EndGInt 1CnstGrupX2EncoInt [nameStrnppAlertButtonSNOOZEtypeInt [defnStrn[1flagInt [EndGInt 2CnstGrupX3EncoInt [nameStrnppAlertButtonSEARCHtypeInt [defnStrn[2flagInt [EndGInt 3CnstGrupX4EncoInt [nameStrnppAlertButtonIGNOREtypeInt [defnStrn[3flagInt [EndGInt 4CnstGrupX5EncoInt [nameStrnppAlertButtonABORTtypeInt [defnStrn[4flagInt [EndGInt 5CnstGrupX6EncoInt [nameStrnppAlertButtonRETRYtypeInt [defnStrn[5flagInt [EndGInt 6CnstGrupX7EncoInt [nameStrnppAlertButtonNEXTtypeInt [defnStrn[6flagInt [EndGInt 7CnstGrupX8EncoInt [nameStrnppAlertButtonBACKtypeInt [defnStrn[7flagInt [EndGInt 8CnstGrupT9EncoInt [nameStrnppAlertButtonNOtypeInt [defnStrn[8flagInt [EndGInt 9CnstGrupT:EncoInt [nameStrnppAlertButtonYEStypeInt [defnStrn[9flagInt [EndGInt :CnstGrupX;EncoInt [nameStrnppAlertButtonCANCELtypeInt [defnStrn]10flagInt [EndGInt ;CnstGrupT<EncoInt [nameStrnppAlertButtonOKtypeInt [defnStrn]11flagInt [EndGInt <CnstGrupX

bug report case # 49384 created.

…and very happy to announce that case # 49384 has been taken care of in 2017r2.1
thanks xojo team!