Anyone know what the NSInternalInconsistencyException is all about? I have code that worked fine built in XOJO 2020, but in 2021r2.1 I am getting a crash with that error when opening a new project in my app.

When running in the IDE, same thing happens, the debugging doesn’t break on the exception,

The error that shows up says "Invalid parameter not satisfying: fabs(point.x) <= NSVIEW_GEOMETRY_LIMIT

Any ideas? Pulling what little hair I have left out on this one!

It means that at some point somewhere, either the OS changed the data types the API used in the past (which has happened on more than one occasion) or the application is passing incorrect values to the API.

This is not an error generated by Xojo, it is generated by the OS, which is why it doesn’t break into the IDE.

Make sure you have you have “Include Function Names” selected under the “Build” section of the “Shared” item, under the “Build Settings” section of the left hand side bar.

Now when the application crashes it should generate a stack report in the crash log, which should help you to figure out where the error is occurring and then you’ll have to step through the code in that routine until the application crashes.

UPDATE - this is definitely being caused by XOJO2021r2.1
I took the same project, loaded and ran it in the IDE of XOJO2021r1.1, and this doesn’t happen. Something change between r1.1 and r2.1.

And I did turn on the “Include Function Names”, but not getting a crash log still. The OS just reports that error, then it quits, but I guess not really a “crash”.

I’d do a feedback report, but not even sure how to explain this one.

More info - also tried in XOJO 2021 r2 and that’s where this problem started. So something changed after 2021 r1.1

I may have to downgrade my project back to 2021 r1.1 just to continue at this point. I’ve wasted too much time already trying to track this down.

Spoke too soon. Tried in 2021 r1.1 again, and now I can reproduce that same error in r1.1.

But my built app done in December 2020 (with XOJO 2020) works fine. That same source code in XOJO 2021 though gets the NSInternalInconsistencyException error when running.

I’m at a roadblock here. Not sure what to do.

You will want to look in the Console application to see the crash log from your app