Not Working on Enterprise Linux

Not to sound sarcastic. Has anyone been able to get XoJo to run on a Enterprise Linux system? More specifically SuSE Linux Enterprise Service Pack 2? Anyways… I have been reading through the forum and did all the things people seem to have been doing, yet no go. Immediate crash, just stops running.

Thoughts?

Have you tried running Xojo from a Terminal to see if there are any errors listed there?

You may need some libraries like libunwind8.
see

Sure does make an error. The IDE starts, and I loaded one of the examples. Database - SQLite Example.

kb6ibb@KB6IBB-15:/opt/xojo/xojo2020r2.1> ./Xojo
libocci.so.10.1: cannot open shared object file: No such file or directory failed to load code unit /home/kb6ibb/Xojo/2020.021.00…51642/Precompiled Plugins/Plugins0GUILinuxGTKx86_64.o: failed to load code unit /home/kb6ibb/Xojo/2020.021.00…51642/Precompiled Plugins/Plugins1GUILinuxGTKx86_64.o: failed to load code unit /home/kb6ibb/Xojo/2020.021.00…51642/Precompiled Plugins/Plugins2GUILinuxGTKx86_64.o: failed to load code unit /home/kb6ibb/Xojo/2020.021.00…51642/Precompiled Plugins/Plugins3GUILinuxGTKx86_64.o: Segmentation fault (core dumped)

The plugin folder referred to in the error is empty.

Remove the Oracle plugin.

Removed the Oracle plugin, same result. Same error message.

I have managed to make some progress. I removed all of the plugins and now I only get the Segmentation fault and a core dump.

What modules did you choose for this installation? Was the Desktop module and/or Development module installed with this setup? Did you select Gnome for this setup? If you’ve got gdb installed with this setup, try running Xojo through gdb and post the backtrace.

I just installed SuSE Linux Enterprise Service Pack 2 with the described setup (i.e. checked Desktop and Development module, and selected Gnome), and installed the Linux/tgz version of Xojo and I was able to launch Xojo just fine.

Somehoe I tested today on Suse 15 and it works after install of Libunwind8

On my system both the 64 and 32 bit Libunwind8 are installed.

Yes, but did you build anything. I can get the ide to come up just fine. Load one of the sample projects, click run, and crash. Segmentation fault, core dumped.

Yes, I was able to run an example project just fine. This could be related to how you installed Xojo, can you try the Linux/tgz version and see if that works?