No longer possible to run 2014r2.1?

OK, got an old project that needs some fixing. The project relies heavily on Threads updating the UI (hear, hear…)
I tried to install 2014r2.1 on Windows 10 but I am not able to add a License, Xojo IDE crashes after closing the “Add License” window.
Also tried on Mac OS High Sierra, but then plugins are not loaded (I guess sandboxing).

Any ideas?

Ask Dana for help.

If something is the culprit it’s app translocation and not sandboxing. Have you done the usual voodoo for app translocation - move the app to the desktop and back?

Tried that, but still no go. I’m booting a VM with Win 7 and will see if that solves my problem.

The answer is to run a newer version of the IDE on that Windows 10 VM to get the license and THEN run 2014r2.1. It works fine here (except for hiding the toolbar).

Hi Mattias, Tim is right, if you have activation issues with older releases, it can help kick the authorizations over to the new system if you Sign In to a 2018 release first (even if you don’t have a license for a newer release and it says that, just Sign In), then Sign In to the 2014 release. If you have more trouble, email me at and I’m sure we can sort it out.

Did the translocation fix from elsewhere on the forum:

sudo xattr -r -d /Applications/Xojo\\ 2014\\ Release\\ 2.1/

…and got Xojo 2014r2.1 on Mac (High Sierra) to work with the old Einhugur and MBS plug-ins to run and compile on Windows 10. Yey!
Thanks for the tips!