No line returns in IE11

Line breaks in a WebTextArea component are ignored in IE11. Two separate lines show up fine in Chrome but only one line in IE11.

I filed a bug report (34720) on this issue but I am hoping someone has a workaround I can use now.

You’re doing it with +EndOfLine+ or with a

Neither, I was just editing right in the editor.

I tried +EndOfLine+ in the text property in shown event and it worked! Thanks!

Why doesn’t this work in the editor?

Feedback case #34682 refers to Transparency in IE11. Is there another case?

You are correct Greg. I messed up. The new feedback case number for this issue is #34720.

If you can edit the feedback case please add workaround mentioned by Jan-Ole: Use +EndOfLine+ and add text to component on Shown event. Apparently, text added via editor in Xojo results in IE11 ignoring the line breaks.

I’m happy that my solution worked for you :wink:
(even if it’s only a workaround)

This still seems to be a bug (which I’ve now run into)…I’ve added it to my top cases. Any idea from Xojo when this might get corrected?


The workaround I posted back in 2015 still works just fine and transparently :

[code]Sub Shown()
dim js as string
js = js + “var ta=document.getElementById(’”+me.ControlID+"’).getElementsByTagName(‘textarea’); "
js = js + “var texte= ta[0].innerHTML; ta[0].innerHTML= texte.replace(’’,’’);”

End Sub[/code]

Eventually, creating a subclass so this becomes part of default is the best way not to be bothered again.