No Controls Show in WebApp Layout Designer

I’m going crazy here. I’ve tried Xojo 2021.2.1 on Fedora 34, Ubuntu 20.04, and Ubuntu 21.04 and all three have the same issue. No controls show in the layout designer for web apps. Is a library dependency missing maybe? I can’t work on any web apps because I can’t tell how they will be layed out. They look fine once I build and run the web app. See screenshot. I selected all controls to show that there are some on the form.

Is GTK+3 installed on your System? All Web 2.0 controls are drawn.

Yes, all GTK+ 3 libraries seem to be installed. I’m using Gnome, so I would think they would all be installed for that to work.

Now I’ve also tried it on the latest Linux Mint and still have the exact same problem. I’m thinking there’s maybe something wrong with Xojo and webkit2gtk-4.0.

Are the rest of you really able to create Web projects on Linux? If so, what version of Xojo are you using? What distro version of Linux?

Thanks!

Is this on a brand new project too? I don’t recall the same issues on a vanilla openSUSE Leap 15.3 with Gnome desktop (latest) with the latest Xojo (2021 R2.1) a week or so ago.

Thanks, @Adam_Charlton. Yes, it’s on a new project, but the same thing happens on the example projects too. I’ll try OpenSUSE 15.3 later today.

1 Like

Ugh. Same thing on OpenSUSE 15.3 Gnome. I’m going to start installing every library I can think that Xojo might need.

That’s really strange as my install is vanilla openSUSE Leap 15.3 Gnome with Xojo. If you launch Xojo from a Terminal do you get any errors on launch or when adding controls in the console?

Yeah, this is really puzzling me. The only error that prints out to the console is the normal error about libocci that is regarding the Oracle plugin.

Do you run as root or using sudo?

Just as my regular user. I switched to Gnome recently after random graphics issues with desktop projects on KDE (more specifically segmented buttons).

I just got it to work! With one big hitch.

So, apparently the problem was that I had my display scaling set to 200% because I have a 4k monitor. I set the display scaling to 100% and the controls show up! However, everything is so small, I can’t really work that way.

Now, I just need to figure out how to get Xojo to work on Linux with display scaling.

Thanks for your help and quick replies, @Adam_Charlton!

1 Like

OK, it looks like this might be a bug that was recently fixed in WebKitGTK. See the 3rd bullet point here: WebKitGTK 2.33.2 released! - The WebKitGTK Project . Now, I just need to get that version installed on OpenSUSE and test it out.

Great news!

I have an update.

I tried Fedora 35 Beta which has version 2.34 of WebKitGTK and … no luck :frowning:

So far, the only way to use Xojo with a HiDPI monitor in Linux that I’ve found works is to use a virtual machine with the guest resolution set to a non-HiDPI setting.

1 Like

I’ve also discovered that the IDE doesn’t do well in a Hi DPI or fractional scaling mode on Linux. Have to run the desktop at normal resolution.

I wonder if Xojo is compiled to include a version of that library. If you haven’t already maybe worth submitting a feedback in the feedback app.

Thanks guys. I’ve created a feedback case here: feedback://showreport?report_id=66226