New Version Won't Run

So… I had to reinstall after a botched upgrade and that meant downloading xojo again. The old version ran great the new version… won’t even start so I am dead in the water as I can’t sort out the issue.

I am running Linux Mint 19.3 Tricia and the old version of xojo2019r3.1 ran fine, but like I said xojo2019r3.2… won’t start and it’s driving me crazy! Especially since I paid for the license to compile and I am in the middle of a project. According to the installer all dependencies are met. Here’s the error when I start from the CLI

/opt/xojo/xojo2019r3.2$ ./Xojo cannot open shared object file: No such file or directory

I am pulling my hair out as I can’t find an answer, let alone a solid reference to…


i think that is a library used in conjunction with the Oracle DB Plugin (OraclePlugin.xojo_plugin). A workaround is for example removing the plugin from the Plugin Folder. - Or installing the needed Oracle Db library File from the Oracle Website.

Best Regards,

R. Landscheidt

FWIW, I also tried 3.2 on Mint 20. There are issues with libwebkit* libraries also. Have not yet succeeded in installing there.

The only difference between 2019r3.1 and 2019r3.2 is that 3.2 can run in macOS Big Sur, so for Linux you can download 2019r3.1.

You can open a feedback case if 3.1 works on your Linux environment and 3.2 doesn’t, check the latest requirements to see if there is anything else needed in Linux for 3.2.

I was thinking along these lines also. I just did not have time to test 3.1 on Mint 20 to confirm that this is a Xojo or a Mint issue. I actually suspect a Mint issue. There are a number of libraries removed from the Debian repositories (and Ubuntu), which would cause a ripple effect on Mint as well. Perhaps Xojo needs to update to newer libraries, perhaps there is a way to find and install the problematic dependencies manually. Either way, I haven’t had the time to investigate thouroughly.

It does seem to be an issue with Mint, not Xojo. I installed 2019 R3.1 without issues on Mint 19.3. 2019 R3.1 will not install on Mint 20 (same errors as with R3.2). I fear that I will be chasing libraries for a while. I downloaded libwebkit2gtk-4…-37_2.28_amd64.deb from the debian repos and proceeded to install. It too failed because of unmet dependencies In this case, libjavascriptcoregtk-4.0-18 (2.28.3-2). I guess that I will download that too and then I suppose, look for the next one… then repeat the process for the other libraries (libwebkit2gtk-3, libwebkitgtk-3.0-0) missing for the Xojo install on Mint 20. Or perhaps, I will test other distros. I like Mint, but perhaps it is no longer the best distro for Xojo.

Set up a brand new VM with Minh 20
Grabbed the Xojo 2019r3.2 tgz and put that on there
Disabled the DB plugins (just to test) and started Xojo
Except for a few warnings in the terminal like

(process:4256): GLib-GObject-WARNING **: 10:04:00.825: ../../../gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x56437629f430' of type 'GSettings'

the IDE started up just fine

On the upgrade to Mint 20… I experienced the same issue with libraries, which is one reason why I came back to Mint 19.3.

@: Ren Landscheidt - I removed the library but still it will not fire up… and now there is no complaint about anything.

Download it from the Xojo website:

Interesting. I downloaded the deb package and tried to install using the package installer. Either the deb package is missing some stuff, or the package installer is missing repositories to fetch dependencies.

I never use the installers :slight_smile:

Hmm… 2019r3.1 is doing the same thing…

Okay so I downloaded the tar.gz and it’s doing the same thing… no warning, error and I removed the Oracle plugin… I am completely stumped.

So I renamed all the directories in my home folder and … tada! It’s working…

Well… now I am having an issue with the license so, waiting on customer service now…

Why would the names be weird ?
But yes I could see that making things behave oddly

No, there are two folders in my home directory

– And

So renamed them both - .Xojo-Old and Xojo-Old and then restarted the dev environment and viola’ everything except the binary build (compile) is working fine. I have a current license and I see it in the newly created .Xojo/Xojo/License Keys but I still can’t create a binary (compile) my project. So I am waiting for customer service/tech support to sort that out.

ah yes
I have 3

drwxrwxr-x  3 npalardy npalardy  4096 Jul 20 10:03 .Xojo
drwxrwxr-x  4 npalardy npalardy  4096 Jul 20 10:03 Xojo
-rw-rw-r--  1 npalardy npalardy  2431 Jul 20 10:04 .Xojo.Xojo

Since Linux structures things differently they are variations of th Application Support Dir, Preferences dir, and the Preferences file

In mya case the following code

dim appSuppDir as folderitem = SpecialFolder.ApplicationData

dim prefsDIr as folderitem = SpecialFolder.Preferences


has the sane native path for both appSupppDir and prefsDir; namely /home/npalardy
and so the rest of those paths we application specific dirs for xojo

You could remove all 3 and restart the IDE and they should get set up correctly
Then login (Help > Sign in) and that will install your licences