New version of MAS app test failure

I released a 1.0 version of an app on the MAS in 2011 and last year I withdrew it from sale because its content was out of date. Now I want to prepare a 2.0 version with sandboxing and IAP. I have set the new version up in iTunes Connect with IAP products. I build the app (latest Xojo release) and create a sandboxed .pkg with App Wrapper 2.5. I install the app from the .pkg and launch it. It quits with error 173 as it should since it doesn’t have the MAS receipt. But I never get the dialog to sign in to the App Store to download it.
Any ideas?

it could be that, in iTunes, you may have first to fill up name, desription etc for the new version.

#1 Make sure that the bundle ID is registered with Apple and that it’s associated with a product in iTunes Connect.
#2 Make sure that it’s been signed with the App Store submission certificate (Generally this is 3rd Party Mac Developer Application).
#3 The App Store agent can get stuck, sometimes it can be unstuck by restarting OS X, sometimes not. If the previous 2 are correct (bundleIDs are case sensitive) and you’ve restarted, try a different machine. When I can’t test from El Capitan, I use my wife’s machine running Mavericks and that normally works.

Sam, thanks for tips. bundle ID is all correct including case sensitivity. Tried restarting this El Capitan machine and also tried a Yosemite machine.

Sam wrote:

I used App Wrapper 3 (upgraded yesterday on this machine) to codesign the .pkg. Then when I dragged the .pkg back on to App Wrapper it said:

Which certificate did you use? If you’d like use the e-mail support function and send me a message, include a link to the package so that I can download it and verify it myself.

I did send Sam the package and he discovered that I was not using the correct signing certificate. Generated the 3rd Party Mac Developer certificates and new provisioning profiles. Now get MAS dialog to sign in. On to the next issue.