New pigpio - GPIO wrapper for Raspberry Pi

Hello everyone,

A new pigpio wrapper has been created for use with Xojo 2019 r3.1 (API 2), Buster (Raspberry Pi OS), and uses pigpio (wiringPi is deprecated). This wrapper is free and is located at the GitHub location: Eugene Dakin pigpio-GPIO.

This is an aid for those who are developing electronics for the Raspberry Pi an their associated electronics.

Special mention for previous data was with the original work for the first Raspberry Pi wiringPi code to Xojo library was with Paul Lefebvre (https://github.com/paullefebvre). Another library was created by Ulrich Bogun (https://gitlab.com/UBogun/Xojo-pigpio) and has been instrumental with the creation of this library.

Teaser: A new Raspberry Pi book has been created and will be released in the next week or two. The book has many examples that exclusively uses the new pigpio wrapper.

8 Likes

I look forward to the new book notification :slight_smile:

1 Like

Great stuff Eugene - love my Raspberry Pi’s - looking forward to the book.

1 Like

Has the new book been published? Is there a link?

1 Like
3 Likes

Hello Eugene, as all samples are written in python, Im happy to see, yes one can do it also with xojo,

So now I have only C/C++ or great cow basic for Arduino and XOJO for my Raspi 4b with JoyPi case.

Maybe there will be also something like mblocks which generate XOJO code instead of python.

BR Rainer

2 Likes

Hi,

Does this mean that wiringPi will not work with Buster, even on an RPi 3B+?
Tim

Hi Tim,

Yes wiringPi works on Buster. If you are using Xojo 2019 r1, the Raspberry Pi 3B+ book uses the Xojo API1. If you are using Xojo 2020 then the Raspberry Pi 4B book uses Xojo API2 code. I am not sure what will happen when either API2 is used with API1 code, or AP1 code with API2 code.

Thanks Eugene,

So when is it mandatory to use the new pigpio?

Tim

From the tests that I ran, pigpio is mostly forward and backward compatible. If pigpio is working on your system, then there isn’t a need to install the newer version.

Im currently using wiringpi - so when is it mandatory to go to pigpio? I ask because when switching over to the newer OS, one of my apps will not run, and that same app runs on Jessie on a 3b+

@Tim_Seyfarth,

Is it possible that applications that are sensitive to timing might not work as well, since the newer Operating System is faster. Maybe check the speed of communication?

Images of previous Raspberry Pi Operating Systems are available at this website: https://downloads.raspberrypi.org/raspbian/images/

The only timing issue is with UART, which Xojo should be managing. Evenso, it should still run. May not work right but should still run…

Thanks for the info tho!
Much appreciated…
Tim

1 Like

Is this pigpio library installed on the latest Raspberry Pi OS? If not where can I find the information to download and install?

PS. I’m very new to Raspberry Pi and could use help.

Thank you @Gary_Scott for posting the link.

There is an example LED project when you download the free table-of-contents at: https://scispec.ca/index.php/books/54-program-raspberry-pi-4b-electronics-with-xojo-buster-edition

This LED project is like a Hello-World for the electronics where an LED turns on and off. It is included to help ensure that the library has been installed correctly and works with Xojo code for the Raspberry Pi.

Edit: grammar

Thank you both. As I read The pigpio library is installed by default on the Raspbian OS (May 2020), http://abyz.me.uk/rpi/pigpio/download.html, is that correct? How can I test to validate before I run any Xojo code?

This should work ldconfig -p | grep pigpio
If pigpio is not installed, there will be no output. Have not tried it as I dont have a PI handy

1 Like

Thanks, @Gary_Scott, I followed the instructions from page 28 in @Eugene_Dakin book and I get unrecognized service. Any thoughts?

image

I don’t have his book yet, but soon will. But looking at this page I don’t see a option for service. http://abyz.me.uk/rpi/pigpio/pigpiod.html

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.