New documentation is hard to love

I am not sure it improved, I hate to say it but the pop up when you click the fake search box is terribly annoying.

Whats worse is that the search results often are not worth anything:

:frowning:

1 Like

Ok I found by trial and error that this one here takes you to the Graphics:

image

Yup that’s a bit odd. # seems to be ‘the thing you have typed’… The bendy arrow is what you will get if you press return without a choice. ie the default choice for for the entered text.

It’s a bit cryptic but at least there are more than 5 results.

By the way I just tried something that worked. If you wish to search for a specific Xojo version, just add it to the search, for example:

WebListBox 2022r1

Nice !

1 Like

This may also lead to misleading results. Here’s an example for which I filed an issue: #69399.
Why did I think that LeftB was deprecated?
This is what I got by typing ‘leftb’ and hitting enter in the documentation’s search:

Still learning Xojo, I do not always have the depth of knowledge to spot this kind of problems (code snippet relates to MemoryBlock). My mind was in the context of RegularExpressions, where the snippet is placed.

Typing the search pattern and then hitting enter, the documentation still serves this as the result.
For beginners who rely on the documentation for building up their knowledge, this can be an utterly frustrating experience.

This issues with documentation are multifactorial and complex. But I have written a small utility program which helps dealing with one piece of the problem. It is a program that displays new and deprecated versions of commands. The example you mention “Integer.ToString” can be dealt with by supplying a filter in this program which will then list all the deprecated/new versions of the command that contain “tostring”. I include an example below showing the state of the program after the user has entered tostring

This program (XojoDeprecated) is free and available at

http://bearboat.net/DepXojo/XojoDeprecated.html

Anybody who is interested can download it and see if they might find it useful.
Once you have a handle on the complete names of commands, be they deprecated or new, it is often easier to deal with the documentation.

This is a Macintosh application.

9 Likes

Website shows as not secure. App needs 10.15.

I apologize for this being a http vs https site. This simply reflects my total amateur status as a web coder/host. I don’t really even know what it means in practical terms that it is a non-secure site.

If someone wanted to post the same app on a “secure” site, they could.

1 Like

Ask your hosting company to activate Let’s Encrypt. If they can’t switch to a different hosting company.

1 Like

You are my hero! I’ve been asking Xojo why this list doesn’t exist, and you’ve done it. Bravo!

2 Likes

Look at Shell, examples with TextArea1:

Did you report the list of item from a Folder into a TextField ?

Looks like the Documentation writer is a scribe, not a developer.

And I do not talk about the Example quality: no redirection to file is show…

I have to agree with the OP on this, the new documentation isn’t very good, but then again, I am one that still prefers the old CHM help files on Windows, they were fast, usually well organized and easily searchable.

3 Likes

In short, it is not because of the used technologyn, but because of the data by themselves…

Google works well for my Xojo queries, finds the new docs, the old docs, the forums, Stack Overflow etc.

1 Like

And now the local documentation is even worst :roll_eyes:

Xojo replaced the individual pages with HUGE single pages with LOTS of content each one at the same time they REMOVED the option to SEARCH in the page as previous documentation. Control + F on windows.

Is this another consequence of not giving support for the NATIVE renderer on windows?

Stop removing features and give propper support for the current native renderer that is already installed on most windows machines.

meanwhile, find a way to enable the in the webkit renderer for the New documentation, it is a real pain to look for something in those absurdly giant pages.

And the option to open in your favourite desktop browser is also gone, I can’t really get my head around removing that then forcing the page to open in the internal htmlviewer which has had reduced functionality for two and a half years https://tracker.xojo.com/xojoinc/xojo/-/issues/58545 only for Geoff to recently suggest the exact same thing in a round about way and for it to almost immediately get scheduled…

I have to say, I really detest some of the form over function decisions xojo makes either by design or by accident.

4 Likes

Yet another problem avoided by not renewing my licence beyond 2019r2 :partying_face:

If he says that you were talking about a different thing… He must know better what you meant and what you want…

And speaking about a bad documentation, there are several mentions of the “windows native renderer” in the DesktopHTMLViewer documentation although xojo decided to ditch the native renderer. Totally ridiculous to add like 200 Mb to an app just to display some basic HTML content when MOST windows PCs already had the New WebView2 runtime installed.

https://tracker.xojo.com/xojoinc/xojo/-/issues/59961

Are you sure there is no option to choose which renderer to use? If this is indeed not the case, it would a massive mistake for sure.

You can open the documentation on the following URL:

http://documentation.xojo.com

You can then find on page, bookmark items etc The old documentation is available on

http://docs.xojo.com

1 Like

I believe the discussion turned to the local (offline) documentation. I might’ve misunderstood though.