Never ending "Fatal Error" dialog box when dropping into the debugger in 2013r2?

I’ve been noticing this more and more in the last couple of days. I am running Xojo 2013r2 under Mac OS X 10.8.4.

After hitting a breakpoint when running in the debugger, clicking on a property in the “Variables” pane causes a “Fatal Error” dialog to be shown. Pressing EITHER of the buttons ("Ignore’ or “Feedback”) simply causes the dialog to close and immediately re-appear, leading to a potentially infinite loop. The only way out seems to be to force-quit Xojo.

This doesn’t happen all the time, but it does seem to happen fairly often on even the simplest new project I can create and put a breakpoint in.

Is there a Feedback case to sign onto? I’ve not found it if there is.

Thanks,

–pt

IF you do happen to do this can you see if there is a report in ~/Library/Application Support/Xojo/Feedback/Reports
There may be one & that would be useful to have

Will try to get it, Norman.

Thanks.

This sounds like feedback://showreport?report_id=24561

I was able to stop the crashing by removing debugger related bits from the Xojo prefs (although deleting the prefs entirely and having a new one made may be safer)

I could get out of the never ending loop (at least once) by force quitting the debug app before clicking the button on the dialog to submit the error.

Norman, I easily duplicated the problem, and looked in the location to which you pointed. Sadly, there were no files at all in that directory. I took Paul’s suggestion, and got rid of the preferences (Xojo, not Feedback). That seems to have solved the problem (for now).

Before trashing the preferences, I also tried your suggest, Paul, and quit Feedback. That did, in fact cause Xojo to get out of the loop, and quit itself.

Thanks for your help.

I see that Norman had fixed this bug. Thanks for the quick work, Xojo!

Yeah this looks like the conversion & handling of old preferences settings