Need Help- Should be off topic

This should be off in off- topic, but right now I can’t select a topic because I can’t seem to do it by the keyboard,

My iMac (late 2013 core i7 OS X 10.9.2) has lost it’s mind … sort of… all of a sudden I can’t left click on anything - that includes activating windows!. I can make menu selections and call up contextual menus with a right click , but I then have to use the keyboard to select the item… It is very hard to do much of anything.

I’ve tried rebooting several times but it does not help… It would be hard for me to do a google search right now so if anybody has seen this before and knows how to recover from it I would be very grateful for the info!


  • Karen

Make sure there’s nothing resting on one or more keys on your keyboard. I sometimes find that my mousepad is resting on the command key.

Also try disconnecting your mouse for a moment and then plugging it back in. It could also be that your mouse is dying.

If unplugging the mouse doesn’t do it, try a different mouse. If it’s a wireless mouse, change the batteries.

My MagicMouse does that when the batteries are getting low.
Lower than 10% and the mouse becomes less magic and more manic :slight_smile:

Note that you can modify how the mouse buttons work in the Mouse control panel. I believe that you can probably get yourself into this situation with the right (wrong?) combination of settings.

[quote=80088:@Richard Summers]My MagicMouse does that when the batteries are getting low.
Lower than 10% and the mouse becomes less magic and more manic :)[/quote]
I’ve completely given up using a magic mouse much as I liked it.
It’d be sitting about 6 inches from my machine & lose connection so frequently I’ve finally resorted back to a plane old wired mouse with a scroll wheel
I do lose the gesture support but not my sanity - well any more than I had already :stuck_out_tongue:

Norman: I had a similar problem with my Magic Mouse. Here’s how I fixed it: I took off the battery cover.

It turns out that the rechargeable batteries I was using didn’t quite make a connection on the + side. Either they were a little misshapen or Apple was too tight in their design, but if the battery cover was on, those batteries would slip in and out of connection. Taking the cover off allowed the batteries to drop slightly, which caused the + tip of the battery to make reliable contact with the mouse.

After taking off the cover you might have to mildly “bonk” the mouse down on the table to shift the batteries into their new position.

Thanks all … I’m at work now… on my Mac at home, while I can start a new thread, I can’t figure out a way to reply.

I was using the magic mouse, but I also connected a wired mouse and that did not help. There was nothing on the keyboard. I use a wired keyboard and disconnected it (in case a key was sticking) and still could not left click.

Mouse settings in the control pannel are fine… I am at a total loss on what to try next when I get home!

Just googled… I have a magic trackpad I seldom use… I bet (hope!) something is on it!

Thanks All,

  • Karen

Is there any chance a second bluetooth mouse/trackpad is causing a conflict?

Ha! That could be it.

I’ve also see this - and other odd effect - happen when people leave their stylus sitting on their Wacom tablet. Jittery mouse pointer is the typical problem.

I had an issue with my MTP eating batteries at the rate of a set every two days. It turned out that every time I slid my keyboard drawer closed, my keyboard cable was being moved onto the touch surface. The MTP was apparently registering this as a touch and was trying to track a ghostly fingertip. It took me a week to uncover the cause. I rearranged my under-desk cabling and it got better immediately.

BTW - I now remove the batteries when I’m going to be away from the office for more than a few days.

That worked for a while then it resumed
And it does it with brand new batteries
I just gave up

My little old USB logitech mouse just works 100% of the time just has no gesture support

It’s a shame, because the Magic Mouse is just about the best mousie I’ve ever used.

I can recommend Duracell rechargeable batteries. They seemed to work the best for me. We had another brand, Tenergy, that were very problematic.

I loved it - just got tired of “Lost Connection” with it sitting a matter of inches from my machine
Switched back to my wired mouse & … hey … haven’t had that happen in months
IF (however unlikely) Apple made a wired magic mouse I’d buy a pair (as my wife has ditched her magic mouse for the exact same reasons)

You must have some weird Canadian interference, ay?

I don’t have that happen to me often… I really like the magic mouse (more than any other I’ve had), but I do wish there was wired one so I did not have to worry about batteries.

It did it where ever I went - USA included - eh :stuck_out_tongue:

Well, I have no idea what that’s aboot.

You guys & yer aboot - you must listen to Newfies who don’t really speak english anyways