Native SqlServer driver 13 on Linux

Anyone tried using the microsoft sqlserver drivers for Linux using XOJO. I wish to go this route because it handles multiple active connections that FREETDS and MBS do not provide.

I waist deep in this and it all appears to work right up until I try and connect and then it gives me error code:1 with a blank error message.
I have verified the installation of the drivers etc using SQLCMD tools and isql etc. Plus it also finds the {ODBC Driver 13…} because it is not erroring on finding the driver etc.

dim DB as new ODBCDatabase
db.DataSource = “DRIVER={ODBC Driver 13 for SQL Server};;UId:xx;PWD:xxxxxx;Database=yyyyy;Trusted_Connection=yes;”

Any help truly appreciated.

I should have mentioned, I’m on Mint 18.1 64 bit edition (64 bit because microsoft driver are built for 64 bit).

Shouldn’t it be

db.DataSource = "DRIVER={ODBC Driver 13 for SQL Server};;UId=xx;PWD=xxxxxx;Database=yyyyy;Trusted_Connection=yes;"

Note the = after Uid & PWD.

Linux driver documentation can be found here:

There is a mention that if you are going to use an IP address, the server parameter should be written this way:

Server = tcp:servername,12345 

Here, servername is the IP address. The port is specified using a comma and the port number.

I was able to get FREETDS working with macOS, but had the same problem with Linux, with either 32 or 64-bit.

Wayne - yes typo on this forum, correct in code… but made me feel good for a few seconds ! thanks.
Louis - Tried but still not working - same Error 1 with no error message. Worth a try.
David - Yes I think I have to go freeTDS, but I have a million lines of code on a huge project where I have nested connections where really I was trying to achieve a driver that supports multi active connections. MBS does have something for windows by using OLEDB but obviously no good here.

Thank you all - what a pity.

Out of curiosity, have you tried to define the data source without UID and PW?
You would specify UID and PW on a separate line. All strings need to be explicitly encoded UTF-8. It is not an issue if all characters are ASCII characters.