Mystery of the missing progress bar

HI All.

I have something “strange” going on with a progress bar on a window in a desktop app. I’m running xojo 2020 r2.1.

When I build a program that has a progress bar (and so far none of the other ones seem to have this issue) the mac version runs just fine. I see the progress bar, and it acts just fine as I expect. However the Windows built version (in windows 10) the progress bar does not show. I have deleted and readded it, moved it to a different location on the window but it never appears.

Any ideas as to why?


  1. Does it appear if you make a brand new project?
  2. Does it appear if you add it to your existing project but with a different name?
  3. Does it appear if you add it to a new window in your existing project?
  4. Do you have any code in if targetwindows then's that turns it off?
  5. Do you have and windows declares in your project?
  6. Have you tried it in the new version of Xojo?

If you have a long-running method that is not in a thread, you won’t see the progressbar on Windows. It’s an OS difference. Even on Mac, it would be best to put the process in a Thread.

If it’s that and not another issue then popping a ProgressBar.Refresh(False) into the mix should get around that but don’t do it too often or you spend more time updating the UI instead of running code.

Even if it’s in a thread it can be that parts of the ui are not updated. Try to lower the thread priority if you see this happening.

ProgressBar.Refresh doesn’t really work anymore.

There was a recent thread discussing this.

first let it visible and put a value in and look if you see this in your running app.
set the anchor correct.

Thanks for the replies, All. I will test and advise.


Hi Tim.

This is not in a thread.
I am using a progress bar to act as a visual representation of the number of items in a specific group. Not what it is made for, but it works aesthetically and I like it so… :smiley:


@anon20074439’s first answer contains good questions, such as “ 1. Does it appear if you make a brand new project?”. These steps would indicate where the problem lies in your specific case.

That is the next step; real life, bill paying work is taking time right now. As soon as I have a chance I am going to do it and let the folks know.

Paying bills… gotta love it Arnaud / :smiley:


1 Like

Had a second to do a test.
Built a new project, and put a progress bar on it. It shows under windows.
Doesn’t explain why the progress bar shows in my REAL program with a mac build but not with a windows build.

Have an idea or two and will update after it is tried.


Nice. Don’t hesitate to ask or provide information which you think can be useful in determining the issue in your specific project.
Searching cases in Feedback is also a great way to determine whether you’ve encountered a known bug and don’t have to spend too much time in trying to recreate yourself.

Found my problem…
I sized my windows with the "available.width / available height thing.
Now it shows up just fine.

Now I need to know how this messed things up. But i will keep trying to find out why, and if I need some more help, I’ll ask.

Thanks to all for their help / suggestions.


Sounds curious, indeed.

You’re welcome.

Now it gets better. On my version of Windows, it shows just fine. I take the same program to another windows 10 machine and it doesn’t show.

This is interesting. If I can find the $$ I’m going to upgrade my Xojo… :smiley:


Your other Windows 10 machine might be corrupted; any other weird behaviours you noticed on it?
At the very least, there are settings that differ there.

Hi Guys.

“Final” (yeah right…) update on this. I ran the program on a windows 8.1 vm and a windows 10 vm and the progress bar shows up fine. But not on my corporate machine. So, as Arnaud advised it might be something with the Windows 10 version I have on that machine.

I’m going to try a different windows 10 version I have running around - somewhere - and if I get any different results I will advise.

Thanks to all for their time and help.



FWIW, I once had weird visual issues with an application (nothing to do with Xojo) under Windows - I got different results from everyone else using the program. Turned out to have been caused by the “theme” I’d selected in Windows.

1 Like

Thanks Julia.

Since my work computer is 99% corporately controlled, I don’t know if I am allowed to change the theme. But I’ll give it a try. Thanks for the idea!