MySQL SSL Connection Error on Windows

When I run my code on my Mac I connect to the MySQL Server just fine. When I run it on windows I get the following error:

[quote]
ERROR 2026
SSL connection error: unknown error number[/quote]

After some googling around I found this:
https://stackoverflow.com/questions/20459056/mysql-and-ssl-connection-failing-error-2026-hy000

Does anyone know how to fix or work around this issue using Xojo?

Also just to clarify, this is a WordPress hosted MySQL database outside of my control. I just need to access its content. I don’t have control over its deployment or configuration.

Take a look at this: feedback://showreport?report_id=51838

Pretty sure this is a server side issue with how the SSL is configured and can only be corrected on the server side of things. Unless you can connect without SSL you’re unlikely to work around it.

At best you might be able to use one of the various Wordpress API’s to access content but that assumes they are enabled for you to use. Otherwise you’re likely reduced to scraping which is usually frowned upon.

Looks like one of the XOJO updates to the MySQL Plugin broke it way back when and because they “couldn’t reproduce it” they closed the case. Makes sense why they couldn’t’ reproduce it since the determining factor is if the server uses yaSSL or openSSL.

Is there a way to re-open this case or do I have to create a new one?

Brock, answering your question on Feedback: my guess is that you need to download Xojo 2015r4.1 from the archives, copy the MySql plugin from that version to the version you are using.

I don’t have the experience to create a MySQL server with yaSSL and then openSSL to make sure this is the issue. Maybe you can do some tests and give more information to Jason. I hope they can change the way the MySQL plugin works, so it can works with your setup (the one you can’t change) with Mac and Windows without the need to change the plugin.

What we know so far:

  • the latests plugin works with Mac but not Windows on some MySQL SSL installations
  • there is 1 report (feedback case), that using the 2017r4.1 MySQL plugin with 2018r1 Xojo, ‘fix’ the issue (your test will be the second report)
  • there is a theory that the problem is when the server uses yaSSL instead of openSSL

Brock, anything you can add to this? I hope you can download 2015r4.1 and test that plugin with newer Xojo.

Some people are saying that it was just a bad version of MySQLCommunityServer, perhaps one XOJO needs to update?

https://stackoverflow.com/questions/43197399/ssl-connection-error-unknown-error-number

@Brock Nash I read feedback://showreport?report_id=51838 and Robin posted today that your sample project returns ‘Success!’

I’m wondering if he ran it on windows though. I’m updating MySQL Workbench on the server and going to try again. But it definitely is failing on windows and I included a screenshot from the app I submitted with it failing

I am having the same issue.
I am connecting to Google Cloud SQL and it works perfectly on mac, but fails on windows.
Replacing the plugin from 2015r4.1 solved it.

In my instance it seems like the newer version of the plugin is unable to “wake” a sleeping SQL connection.

I now send a CURL request to my webserver to wake up the sql database every time I need to connect in my code as a work-around instead of having to swap out the plugin. I’m curious if this is the same issue that others are experiencing.

What happens when you add Self.SecureAuth = False ?

I once had a similar sounding issue and it had been solved with this, if i remember correctly.