mysql auth protocol

I have a problem after going from RB2011 to Xojo because apparently the mysql database that I am using does not use the new authentication protocol that is triggered (I assume) by the connect method. Is there an option to force Xojo to use the old authentication protocol (that apparently was used in RB2011). According to the provider there is no option for disabling secure_auth at the server side because it is a shared environment.

I have to add what the provider chatted to me:
The issue is described in details here:
Please check version of PHP used for script. According to the article, the issue may be fixed by downgrading PHP version 5.3+ to version 5.2.