Munged Project 2019r1.1

I do “Save As” for binary projects for “version control”.

I have a module with bunch of modules embed in it hierarchically…

Somehow one of the sub module “disappeared” from the IDE and when i try to run I get a bunch of errors from it being missing…

BUT If I save the project as XML or Text it is still there… But as a top level module… though as I said it does not show up in the navigator.

Opening up the immediately prior binary version the IDE show it to be where it is supposed to be but ALSO at the top level. If I delete teh ghost top level version, the one where it is supposed to be loss all its contents…

Basically somehow the the IDE has gotten confused as hell!

Copy and pasting the module to where it is supposed to be does not help…

How can I recover from this?


What is the name of the module that is giving you trouble?


I tried renaming the base module (MicroPlate to MicroPlateX) and created a new one with name MicroPlate and manually copied and pasted everything that should be in MicroPlate into it. I then deleted MicroPlateX and the misplaced top level VelocityReport module.

When i tried to Run I got the following error:
MicroPlate contains VelocityReport, but this is not supported.

Which makes no sense.


Anybody have any suggestions on how I can recover the project? I can’t afford to loss the work done between today and the last save that as not munged.

I was saving regularly but I had not touch any of those hierarchical modules for sever days… I was working on other parts of the project and did do multiple Save As versions in-between , but had not done a run… and so did not know they were munged until today.


I decided to bite the bullet and update the last good version I have and recreate the last 3 days of work… I don’t know if the project is fixable and need to keep moving on it… It should go faster the 2nd time … sigh…

I wish I knew how the project got into this state so it does not happen again…

Odds are whatever let it happen it is probably still in the current/beta IDE.

Things like this can really cost a lot of time… but without knowing how to reproduce it, reporting it is pointless

But that said, as Greg asked me what name of the module is, I suspect Xojo inc has seen or heard about this issue before.


I do recommend true version control via git with the text format moving forward.

We’ve seen situations like this when users have:

  • Managed to get special characters into their class/module names causing problems with saving. On macOS that’s : and /.
  • Directly edited the project manifest file instead of having the IDE do it.
  • Given a module the same name as a Folder at the same level in the project.
  • Loaded Xojo projects generated using tools other than Xojo.

None of those apply here.


Use version control or at least external items. Check in often.

I’ll contact you privately about this.