Multiple webapps


what can i do to deploy multiple web apps?
I buildt a standalone with port 1025.
On firefox i entered “ :1025” an error 404 appears.
AH02811: script not found or unable to stat: /usr/lib/cgi-bin/test_1 :1025

On firefox i entered “” an error 500 appears.
AH01220: Timeout waiting for output from CGI script /usr/lib/cgi-bin/test_1

If i enter the old cgi “” it works!

Remove of .htaccess has no effect.

What else can i do?

Every standalone app must have a different port.

Also, you say that you are building standalone, but your urls are cgi?

Yes, at the moment i only have a working CGI and a not working standalone on port 1025

Ah, the port number is in the wrong place…
This: :1025

Should be

Oh, the documentation is very unclear without the path.

i tried:
and but no connection to server, no errorlog

Should i delete the .htaccess and config.cfg???
I’ve tested it: no effect

Is a Xoj standalone web app a CGI?
Maybe the server is blocking the Xojo file? is running
But i don’t know why! I drunk a cup of coffee and now it works… Strange!

I think i should quit working…
The web app is extremely unstable. If i start the app with my smart phone the app starts and then it shuts down. After some time i can start again. Maybe it’s a result of timers / android…
Or the server doesn’t like this kind of CGI / port

The CGI program should be deployed on a Web server such as apache, and the port is configured by apache. I’m deployed on a Ubuntu server. Multiple CGI applications deployed on the same server can’t have the same Application Identifier, otherwise opening multiple applications at the same time will fail.

He’s building Standalone apps.

If it’s a stand-alone application, you shouldn’t have to enter a path like / CGI-bin / test_1, you just need an IP address + a port number to open the Web page. If you’re building a CGI application through a template, you can only run it on a web server like apache. This is just an interface program for post or get to get data. I’m using CGIApplication to build various post and get interfaces. If it is standalone, it is a daemon on Ubuntu and must be executed on the server before using it.

Hello again!

I wrote a new xojo standalone app for port 1025. Without Timer, slider,…
The test on a Linux PC is positive with
And it works on Android! :slight_smile:
But after 10 min the server shut down.
No connection to server:
… i tried every thing and combination

Nothing works! No message in error or access log.
My old CGI app is stabile working, even on Android!
I am an absolute newbie and for me it’s the question what is wrong?
My Xojo standalone app the server configuration or …

Strange. If i rename the standalone app in test_1.cgi it works
But after 10-15 min the server shut down.
No connection to server!

If it shut down then the app quit and will have to be restarted. You’ll need to add some logging, probably within the App.UnhandledException event to start, to figure out why it’s closing on its own.

Now i have an error log:

[Wed Oct 31 07:53:26.274940 2018] [cgi:warn] [pid 29781:tid 139996715386624]  AH01220: Timeout waiting for output from CGI script /usr/lib/cgi-bin/Reichweitentest_Android
[Wed Oct 31 07:53:26.275040 2018] [cgi:error] [pid 29781:tid 139996715386624]  Script timed out before returning headers: Reichweitentest_Android
[Wed Oct 31 07:58:26.374941 2018] [cgi:warn] [pid 29781:tid 139996715386624] AH01220: Timeout waiting for output from CGI script /usr/lib/cgi-bin/Reichweitentest_Android
[Wed Oct 31 10:41:18.471089 2018] [cgi:error] [pid 29781:tid 139996698601216]  AH01215: Runtime Error: /usr/lib/cgi-bin/Reichweitentest_Android.cgi
[Wed Oct 31 10:41:18.471240 2018] [cgi:error] [pid 29781:tid 139996698601216]  AH01215: Please report what caused this error along with the information below.: /usr/lib/cgi-bin/Reichweitentest_Android.cgi
[Wed Oct 31 10:41:18.471275 2018] [cgi:error] [pid 29781:tid 139996698601216]  AH01215: Common/plugin.cpp: 990: /usr/lib/cgi-bin/Reichweitentest_Android.cgi
[Wed Oct 31 10:41:18.471360 2018] [cgi:error] [pid 29781:tid 139996698601216] AH01215: Failure Condition: pluginEntryTable.GetEntry( entrypointName, out ): /usr/lib/cgi-bin/Reichweitentest_Android.cgi
[Wed Oct 31 10:41:18.471452 2018] [cgi:error] [pid 29781:tid 139996698601216]  AH01215: can't find plugin method Crypto.SHA1(data As MemoryBlock) As MemoryBlock: /usr/lib/cgi-bin/Reichweitentest_Android.cgi
[Wed Oct 31 10:41:18.687715 2018] [cgi:error] [pid 29781:tid 139996698601216] End of script output before headers: Reichweitentest_Android.cgi
[Wed Oct 31 10:46:51.679271 2018] [cgi:warn] [pid 29781:tid 139996522567424] ] AH01220: Timeout waiting for output from CGI script /usr/lib/cgi-bin/Reichweitentest_Android
[Wed Oct 31 10:46:51.679420 2018] [cgi:error] [pid 29781:tid 139996522567424]  Script timed out before returning headers: Reichweitentest_Android
[Wed Oct 31 10:51:51.693607 2018] [cgi:warn] [pid 29781:tid 139996522567424] AH01220: Timeout waiting for output from CGI script /usr/lib/cgi-bin/Reichweitentest_Android

Now i can’t start again. The old cgi is still running.

That log is from the system and refers to the cgi version of your app.

Let’s step back for a minute.

First, Please move your standalone app out of the cgi-bin folder. That’s severely confusing and complicating matters here.

Then launch your standalone app from the command line and try to access it from a browser simply by typing

No additional path needed.

I have two versions:
a running CGI version

and a standalone on port 1025 i renamed in xxx.cgi
I will remove the xxx".cgi" and
“move your standalone app out of the cgi-bin folder”
Where should i place it? In the /var/www/html ?
And the additional folders for Libs and Resources?

I think the idea to have a standalone web app is that you don’t need to have a web server installed. So I guess you can put the web app wherever you want, you then go to your server’s shell and execute it as ./webapp

I worked hard for weeks, rent a VPS, installed a server and apache and you mean a standalone works everywhere??? Honestly?

I’m just saying that a standalone web app work on your server without apache, yes.
For cgi you need apache (or nginx or other web server). At least that’s what I understand.

My server runs with ubuntu. I placed the standalone and the folder in /var/www/html but no connection to the server.

Ubuntu 32 or 64 bit?
Did you copy the app and the directories created by Xojo to /var/www/html ?
Did you execute the app from your server’s command line?

I have an Ubuntu VPS running apache and nginx with a Xojo .cgi. Later today I’ll build a stand alone version of my cgi and, for the first time, copy that to my server and execute it. Then I’ll have a little more experience to help you.