MSSQLServerDatabase plugin on Linux

Under the MSSQLServerDatabase documentation:

This plug-in is a Windows-only feature. Other platforms will get a PlatformNotSupportedException when any method is called.

Is this something that can/will ever change in a future release? Also, just curious why this limitation is in place (my guess is because the plug-in Xojo uses in minimal, and simply just communicated via the native SQL server client, which is a Windows OS-only piece of software… but just want to confirm)?

That’d be about right
It uses the official MS libraries which are Windows only

Appreciate it, Norman. This sucks, but I’ll find another solution… either ODBC, or compiling the service application for Windows instead of Linux and getting it to run that way.

You can try MBS SQL Plugin instead.

That uses FreeTDS ?
If so there are some issues with FreeTDS and MS SQL server folks should be aware of
But it’s a reasonable option on other platforms where MS does not provide an SDK

Is the mbs plugin using the latest version of freetds?

As you provide freetds library, you can use whatever version you like.
Last time I simply used the one coming with the distribution.

[quote=127574:@Christian Schmitz]As you provide freetds library, you can use whatever version you like.
Last time I simply used the one coming with the distribution.[/quote]
Yes, that’s good for those who know how to build it.

But I’m referring to the download provided by you:

The readme does not state any information about the version. I guess it is version 7.2, supporting SQL Server 2008 so.
(otool -l is not giving me any information I currently would understand)

FreeTDS is a pretty darned good replacement for MS not having a library that can be used on other platforms.
And it works pretty darned well - except when it doesn’t - and there are a handful of things that newer versions of MS SQL support that FreeTDS doesn’t. My comment was more about “educate your self about this & work / design accordingly” so you don’t run into these issues.

The library is just for people who don’t want to build their own.
On the date you should be able to see how old it is.

I still can’t get the SQLDatabaseMBS plugin to connect to MS SQL Server on Linux (Mint, Ubuntu or CentOS) using FreeTDS — I have it working using FreeTDS on Mac (Windows doesn’t need it). I have tried installing every library mentioned in Google searches and linking to every ‘’ file but it never connects.

Has anyone solved this?