Mojave killed my app

This morning, I got the kind of message I dread :

I told the customer a new version will be available soon, but I have no idea what is going on.

Grin… you got a link for a test version? Is the user capable of checking the console logs? may show a message as well as running from Terminal.

it may be missing privacy string in info.plist.

I had 2 apps that refused to open after the update to Mojave on my personal system. It turns out that Gatekeeper was locking them via Security and Privacy in the “Accessibility” section, but the notification wasn’t appearing to ask permission.

The customer has an old version. Some like 2 years old.

I tried the latest version of Check Writer+ under Mojave, it runs as expected.

I am going to send her a promo code for the latest version in the MAS. With some luck it will solve the problem.

There is - maybe (probably ?) - a lack of explanation (sent to the general public) about what happens in all brand new OS version(s).

In the old time (20/30 years ago), list of compatible applications (the most know software / compatible to the new OS version) was created (at Apple were I was working /involved, sometimes) and given to the press …

Yes, when the OS had a price, the upgrade price had to include applications upgrade too.

I think I never read that an APFS volume cannot be read by… El Capitan driven computer (for example)…

Computer Web news sites talks about OS’s alpha, beta and are in silent mode for the released version (or they produce a book they sold).

On my Mojave an old Photoshop and some other apps did not run. The (strange) solution for me was:

  • Go to System Preferences
  • Security & Privacy > Accessibility
  • Add the app to “Allow the apps below to control your computer.”

Apple did increase the security checks in Mojave and I think in the case of Photoshop CS5 it was scripting stuff or some locations on the disk that are now blocked by default.

This is exactly what I was taking about above. A couple of my old music apps didn’t launch any longer. The “Allow app to control my computer” setting solved it.

There’s a lot of complaints about this; it appears that for apps built against older SDKs, Apple choose to make it crash. For newer apps, you need to have the appropriate privacy strings.

It’s caused a lot of frustration as users have no idea what’s going, some are aware that it’s Mojave, but a lot think it’s 3rd Party developers.

Sadly until a guard change at Apple, this is the kind of stuff that we can continue to expect from the almighty Apple. One day it will catch up with them as users get fed up with crappy OS updates and constant incompatibilities.

@ Sam Rowlands : What do you mean by “appropriate privacy strings” ?

@Francois van Lerberghe: see for instance here . Because this makes users so much safer.

In App Wrapper 3.9, I’ve added a new panel called “Privacy”. In this panel, you set some descriptions for the privacy options.

where is this located???

macOS System Preferences -> Security -> Privacy -> Look for the blue Icon with the Human Figure in a Circle :slight_smile:

under Accessibility… thanks… i notice that when i connect to client with Mojave on logmein123 and i can’t control their machine until they give permission on the accessibilty tab

it’s the same for teamviewer.

its the same for all remote access clients.