Mojave b2 issues (older apps crash on start, black Listbox header)

Does anyone else see these issues with recent macOS 10.14 betas:

Running any app built with RS 2012r2.1 crashes on launch with an apparent over-release around a posted notification (NSNotificationCenter).
Or do anyone’s Cocoa apps build with Real Studion work on Mojave for you?

Some of my apps (FAF, Prefs Editor), built with Xojo 2017r2, show a black bar in its Listbox header rows. Forcing a refresh by resizing the window leads to a garbled header row. Anyone else seeing this? (It has nothing to do with the new Dark Mode in Mojave)

I like to know this to decide whether I should report this to Apple or not.

For Number 2., yes and it has been reported already to Xojo and has been verified by Xojo Inc.
feedback://showreport?report_id=52399

Also, it seems Xojo doesn’t delete the debug.app completely any more after the app has quit.

I just had this happen when running my apps remotely, but have seen this on local runs before as well. Is that a known issue, too?

The black headers is not the only problem. The cellpaint event also triggers issues. Drawing an image with alpha channel is troublesome (the alpha channel is painted black).

Not to mention all other issues with controls when turning on dark mode.

Well, I guess it’s time I finish my Listbox drop-in replacement that’s using NSTableView and NSOutlineView, then :slight_smile:

(Actually, it should already be included in the MBS Plugins Demos, and be working pretty well)

Oh, it seems apps built with Xojo 2013r3.3 crash on start as well, but differently than with RS 2012r2.1: I see a recurring “segmentation fault” crash around NSView, NSCell.

Anyone else seeing that their older Xojo-made apps crash on start?

I have problems with the 32bit version of my app which seems to crash a lot when using AppleScript. Christian fixed the black alpha channel problems in the latest beta. The header of the NSTableView listbox is fine. The only - really minor - problem is the appearance of toggle buttons in a toolbar: feedback://showreport?report_id=52422

Maybe somehow related to feedback://showreport?report_id=52407?

I remember seeing a report in Feedback about this issue. I had similar issues using Xojo 2017r1 which was fixed in 2017r3 or 2018r1
I think it has to do with APFS

EDIT:
feedback://showreport?report_id=49147

Posted this in the wrong thread last night - rather embarrassing.

In the upcoming edition of xDevMag, I’ll show you how to fix a lot of the controls, but the list of header is not one that I could solve.

Icons in the list box are solved by drawing them yourself.

I’m currently working through some PopOver issues at the moment. DO NOT CALL [NSPopover appearance:], it should work according to the docs, but in reality it simply fails, no errors, no logs, it fails and no other code in that event loop will execute. This is an Apple bug.

There’s also some consistency issues between the dark mode on pre-Mojave and Mojave, which I’m also working through.

Since upgrading to Mojave Public Beta 18A336e, the IDE does not draw a window’s frame anymore.
Anyone else seeing this? Everything is fine when the app runs, but window design is a bit annoying this way.

With beta 6 the listbox problem (black header) is solved !