Missing private keys to notarize apps, AppWrapper won't work

I dont know what I did. I am using AppWrapper and its failing on wrapping and notarizing the app every single time. I tried reinstalling the certificates and more and nothing is working.

Can I reinstall these missing keys? I tried importing them from my old MacBook but they won’t install on my new MacBook


Did you download your certificates via the Apple Developer website? Often this results in missing private keys in the keychain.

Please use Xcode (Preferences > Team > Manage certificates) to properly manage your certificates…

1 Like

If you are missing private keys to notarize your apps, AppWrapper won’t be able to help you since it requires the private keys to sign and notarize your apps.

Here are some steps you can take to try to recover your private keys:

Check if you have a backup of your private keys. If you use Time Machine or another backup software, check if you have a backup from before the keys were lost.

Contact Apple Developer Support. They may be able to help you recover your private keys, but this is not always possible.

Generate new private keys and re-sign and notarize your apps with the new keys. This may not be an ideal solution since your apps will need to be re-distributed and users may need to re-download them.

If you have enrolled in Apple's Developer Program, you may be able to use the "Automated App Signing" feature to sign and notarize your apps. This feature allows Apple to manage your private keys and signing certificates, so you don't need to worry about managing them yourself.

In the future, it’s important to keep your private keys in a safe and secure location and to create backups regularly to avoid situations like this.

MODERATOR EDIT: Link to ad removed