Missing app icon on Linux 64 bit

I’ve built a simple app for both OS X and 64 bit Linux. Both apps work as expected but there is no app icon on Linux. I added the required icons to the App Icon editor in the Xojo IDE. The app icon appears as expected on OS X but not on Linux. Is this a known bug? Running Ubuntu 15.10 64 bit.

Where are you expecting the icon to appear?

When I run the app, the app appears in the unity launcher bar with a generic icon only

Probably a missing desktop file (which is something the IDE does not create for you)


Ah, any reason the IDE doesn’t create one? What’s the point of allowing the inclusion of an app icon if it does nothing on Linux? Do we need to create a custom installer for Linux apps then?

the file needs to have absolute paths :slight_smile:
since we dont have a clue where you are going to put it we cant create one thats correct

installers will vary for linux - either deb’s or rpms or there’s always tgz’s
should you include one ?
really depends on the target audience

I’ve just had a look at Ubuntu 20.04 64Bit.
Again… no Application Icon is shown in the Launcher for any Xojo built app :frowning:

Even when creating a .desktop file (saved on the Desktop).
The Shortcut on the Desktop picks up the Icon, but once launched using that - still no AppIcon in the Launcher for the currently running Xojo-built application.

Workaround: Manually set the Icon using a Declare

Declare Function gtk_window_set_icon_from_file Lib "libgtk-3" (windowHandle As Integer, filename As CString, error As Ptr) As Boolean

An example project is attached in <https://xojo.com/issue/60293>

Has anyone found a way/workaround for a Wayland based Linux Distribution (e.g. Debian 10.2)?