Method parameters displayed in IDE

When displaying methods in the IDE, the method parameters are also displayed. This was not happening yesterday so I must have inadvertently turned this feature on. How can I turn it off?

Xojo/Preferences/Navigator? Or do you mean something different? A screenshot of what you mean would help.

This just happened to me too. All of a sudden the method parameters are all written out in the Navigator. I find this annoying and I don’t want it.

Xojo > Preferences > Navigator does not appear to provide any option for controlling this behaviour. What am I missing?

Nothing. I see this often. Just restart Xojo IDE. :wink:

Thanks, that worked.

How silly…

This is a bug. Here are the steps to reproduce it:

  1. open any Xojo project
  2. open the Xojo Preferences window
  3. close the Xojo Preferences window

Congratulations, all we did was open the Preferences Window, and the Navigator gets polluted with lots of unnecessary text, with no way to turn it off except to reboot Xojo.

feedback://showreport?report_id=54980

That explains why i see it often. I constantly install new Plugins and each time i wipe the Ceches via the Prefs Window. :slight_smile:

Thank you for report it!

I like the method signatures in the Navigator. I’ve solved a number of problems that I’ve created using GIT where the pull resulted in the old version AND the current version in the project.