MenuItem Separator Not Showing

This issue is driving me crazy! I am using Xojo 2021 Release 3 with a Desktop Project in Windows 11. I have added a separator to MainMenuBar. The MenuItem settings are set to Visible = True and Auto Enabled = True. The Separator looks fine in the IDE, but when I run the application the separator does not appear in the menu system. Am I missing something here?

Long shot:
Is it still of type MenuItem, or has it become a ApplicationMenuItem / PrefsMenuItem in the inspector?

The Super says MenuItem.

1 Like

(On a mac, the other options could have made it appear elsewhere than where you expected to see it)

As a test, I created a new project with a MenuBar system. I was able to successfully create a Separator in the new project. But that does not resolve my issue with the menu system in my main project. Is there a way to create it programmatically?

Thanks Jeff. I do not see it showing up anywhere else in the menu system when I run the application.

Jeff. I did notice, in the new test project where I was able to successfully create a Separator menu item, the Super was a DesktopMenuItem which is the new API. So I am assuming that with the old API, we can no longer create a Separator Menu Item.

I confess I want nothing to do with API2.
Does creating a normal menu item and setting the text to be “-” still work?

Yes. Creating a normal menu item still works with the old API.

1 Like

Sorry. This was my mistake. I had code in the Window that was hiding a test MenuItem at the same index as the Separator I was trying to add.

1 Like