Menu disable in Xojo 2024r1

I openned one of my project in Xojo 2024r1 and all my submenus in my menus “File” - “Edit” - “Options” - “Help” were disabled. It worked fine in previous Xojo version.
I had to create them again (“File” - “Edit” - “Options” - “Help”) and I moved inside them all my submenus “New game…” - “Create combination” and the other. My application worked again as expected.
I save my project as “Xojo XML Project” (instead of “Xojo Binary Project” which the default for all my projects) and I compared it to the previous project.
I see that the lines 0/1 were set to 0 in the project which didn’t work and 1 to the project I corrected. But in Xojo, there is no way to change that.
How did I put this value to 0???


I have had this problem also and I resolved it by adding :

MenuFile.Enabled = true
MenuEdit.Enabled = true
//etc... for each of my menus

in the Event Handler “MenuBarSelected”
But I don’t know if it is the better solution.

Exactly as I did.
I don’t think there’s a better way, since there seems to be a new bug in the framework.

I don’t think it’s the framework. Xojo should save (and or read) 1 if it is a menu as we can’t change it and it is supposed to be MenuAutoEnable 1 /MenuAutoEnable .

I guess it may be broken. Xojo seems breaking the menus (I don’t now how and why) and fixing partially every iteration.

This one was “fixed” in 2024r1:

This one will come “fixed” in r2:

Not sure what still broken, but a sample and steps to reproduce should be put on an Issue Report for inspection.