Media/Photos doesn't appear in a file open dialog. Why?

Hi all,

I want my users to import image files from their “ library”. So, I implemented to open files via file dialog like:


Dialog can be opened, but when I click “Photos” of Media section on the sidebar, nothing is shown.
Photos in library must be appeared here, I think.

It works fine on Yosemite (with, but seems not to work on El Capitan (

Why does this happen?
What should I do to avoid this?

Try restarting. Open dialogs are a mess in El Cap, and I frequently have to fix mine by restarting.

Thanks Tim.

OK. I restarted my app and rebooted my Mac, but no change is found…
Any ideas?

Does it work in 64-bit?


Downgrade back to Yosemite.

Have you tried an OpenDialog with the filter of “public.jpeg”?

Thanks all!

I tried it, but nothing is changed.

I tried it too. But OpenDialog with “public.jpeg” filter behaves as same as “GetOpenFolderItem”

Yeah, I built in 64bit app, It WORKED correctly! I could see photos of Media/Photos in the dialog. Great!

How different between 32bit and 64bit?
Does not accept the access from non-64bit app?

Oh yeah, goes to show how often I use Apple’s Photos tripe. No longer works in 32-Bit, only 64-Bit. Nother bug in El Capitan!

Sam… :slight_smile:

Constantly bashing El Cap. :wink:

[quote=267143:@Sascha S]Sam… :slight_smile:
Constantly bashing El Cap. ;)[/quote]
I wouldn’t have to if things that used to work continued to work. At least once a week, I find something that’s now broken. I’ve given up filing bug reports as none have gotten any traction since El Capitan GM.

I can understand you, but i am much more productive on OS X then on Win. I think it’s still more reliable.

And while the OS is developing faster with each year, i expect more issues in new releases. And i like the challenge of working around such quirks. But OTOH i do not make a living with Xojo Apps. :wink:

[quote=267140:@Toru KOBAYASHI]> Michel
I tried it, but nothing is changed.[/quote]

Anyway, this is the proper way to set a mime type. What you used is not a mime type.

About your problem : have you verified the folder actually contains jpg files ? Or pictures for that matter ? Because of a bug, the filter is actually not honored, and the dialog will permit picking png, gif or anything else.

Here under 10.11.5 the folder at /Users/Mitch/Library/Containers/ contains only two folders and no pictures :

ThumbnailsGenerators Mondrian

I did verify that Photos contains pictures. They may simply be hidden somewhere else. Maybe in an archive of sorts.

There is another Photos folder on the system, in

/Library/Application Support/Apple

But it contains no Photos either. What is in the Photos folder you show on your screen grab ?

I logged with Apple a while back and they basically said forget about it for 32 bit.