Maybe a XOJO bug

I have a web app that uses some segmented buttons. When a (slide down from the top) dialog is displayed any page subsequent to that shows the segmented buttons with a corrupted image.

This image is what the buttons look like BEFORE the dialog is displayed:

This the dialog:

This what the buttons look like AFTER the dialog is displayed:

I have ZERO lines of code that do anything with these buttons.

I have NOT tried this on my Linux Web server. These screen shots are from my Mac with a RUN.

Segmented Controls have some issues. I have seen this but I don’t remember what we did to correct it. I will see what I can find.

Bob,

I previously encountered this before but it seemed to be random. Now that I see what causes it I probably just had a navigation sequence that was not typical so it appeared to be random. Now with a new UI structure I can reproduce the problem every time.

Previous “tinkerings” with the segmented button to isolate the problem seemed to show it was related to size or position but nothing was consistent.

I have tried it on my Linux server and the results are the same so it appears to not be platform specific.

Is there an official XOJO bug report?

Thanks.

Some similar but not the same bug reports:

feedback://showreport?report_id=15652 WebSegmentedControl labels with Spaces in them are drawn incorrectly on page load

feedback://showreport?report_id=13758 WebSegmentedControl doesn’t save its width property correctly if it has more than 2 segments

feedback://showreport?report_id=18772 WebSegmentedControl Doesn’t Use Styles Properly

I’d say post your own feedback report with an example project. The more the merrier.