Maria DB

Installed MariaDB with Homebrew now I just need to get my Navcat to connect to it?

The connection details are:

host: localhost
Port: 3306
user: root
pasword: empty, blank

Getting 1698 - Access denied for user ‘root’@‘localhost’

What do I need to do?

You need to grant permission in the db

how I can’t connect?

Usually theres a config file you need to alter to enable tcp connections
You use a text editor like vi, nano, pico, emacs etc often to change that

I’m sure MariaDB has documentation that tells you how to do this

The docs say password is blank and that it can only take connections from localhost.

For a connection to MariaDB on my Synology NAS I use the port 3307. Maybe port 3306 is wrong?

Yes, but you need to run the MariaDB Admin app on the localhost then change the access to ‘%’ ie all IP addresses can connect, not just localhost.

You need to run mysql_secure_installation after you install MariaDb. See:

this link

Peter.

@David Cox

How do you run MariaDB Admin?

From their Knowledgebase:
https://mariadb.com/kb/en/graphical-and-enhanced-clients/

I have Navicat, nothing for MacOS. But I can’t connect with navicat. In a catch 22.

Is Navicat running on the same PC as MariaDB? Are you connecting as 127.0.0.1 (useful if localhost doesn’t work)?

Yes I need a local copy to mirror Xojo Cloud. I connect to the cloud fine, local I get 1698 - Access denied for user ‘root’@‘localhost’

Have you tried 127.0.0.1 instead of localhost?

Yes same result.