Malicious Termination Occurred

Not sure if this is the right forum area but here goes:

I’m getting the "Failed to connect properly. Malicious termination occurred’ when I try to connect to my Raspberry Pi 4 for Remote Debuggin. OS is Version 10 of Raspbian 10 (Buster) and Xojo 2020 R2.1. I’ve opened a port that was mentioned in another thread (44553) to no avail. I’m running Windows 10. Any other things I should try. Thanks in advance

In the debugger stub, make sure the IP address is what you expect. It must be on the same network as the computer you are running from.

Debugger Stub, ok, I see a RTFM moment here, I thought you could just fire up the remote debugger after you set it up. The I.P address of the Pi is good since I ‘Filezilla’ to it to transfer files, time for some research unless you can give me a quick ‘Cliffs notes’, I don’t mind looking at the online docs. Thanks
Greg

In the remote debugger window itself, it should be showing an IP address. Make sure that is correct.

Yes it is Greg

And on the Raspberry Pi side?

What do I need to do there?

Here’s what it looks like on my machine, it is this address that must match the one in the IDE:
image

Yes it does Greg, I did a hostname -I on the Pi

I’m not sure why you and I are having a disconnect… but when you run the remote debugger stub on the pi, there’s a window there. it should look very similar to the screenshot I sent. That window is what I’m asking about.

Ok that’s the disconnect Greg. I’m missing the steps on how to run ‘the stub’ on the Pi, what is a stub?, is it a separate compile program?, Sorry for being obtuse, I’m obviously missing something. Let me read the docs so I can get up to speed

Look in the Extras directory next to the IDE. There are two folders named Remote Debugger Console (for systems which don’t have a GUI) and Remote Debugger Desktop (for systems that do have a GUI).

I suggest for the time being that you use the Desktop version until you are familiar with how all this works.

Copy the Linux ARM.zip file to the Pi, decompress it and run the enclosed app. Then you can run from the IDE.

Reading that now. Thanks Greg, I should have read the docs first

Got it!!, ok feeling quite stunned now. Thanks so much for your help. RTFM Saturday

2 Likes

I’m back at it. When I select ‘Run remotely’ and I have the remote debugger desktop running, I see listening on the port but it’s not firing up my app on the Pi?, what am I missing?

Thanks

Make sure that in the IDE, left hand pane, you select Linux, then in the right-hand pane of the IDE (Inspector), you select the build achitecture that matches the Pi.

If you don’t do this, it will load the app to the target but it won’t start. And unfortunately it doesn’t tell you, either.

What I had done was some testing in my Linux VM between testing with the Pi, and I forgot to switch the archtecture.

Yup , both correct

My Linux VM needed x86 64-bit architecture, the Pi needs ARM 32-bit.

Also, get rid of the password for the connection unless there’s a reason for it.

Removing the password did it, thanks Tim!

Good. Oh, the other mistake I made was to accidentally turn off “Launch executable after receiving” by a random click. I’d say once you have the setup OK, just minimise the debugger stub to the Dock or whatever it’s called and leave it running.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.